Applescript dictionary nonexistent/unopenable

RESOLVED DUPLICATE of bug 608049

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 608049
14 years ago
4 years ago

People

(Reporter: Chris Andrichak, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040113

firefox does not seem to have an Applescript dictionary. Checked with 0.8
release build.
Reference bug 202340 for an explanation/possible fix.

Reproducible: Always
Steps to Reproduce:
1. Run fireFox
2. attempt to open dictionary with script editor
3.

Comment 1

14 years ago
confirmed.
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; ja-JP; rv:1.7b) Gecko/20040317
Firefox/0.8.0+

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

14 years ago
Maybe I am jumping the gun a bit here, as a simple script does not even work
when run against fireFox. A script which works against mozilla (And it compiles
as shown):

tell application "Firefox"
	activate
	get URL "www.grope.com"
end tell

So does fireFox not even have scripting capability?

Comment 3

12 years ago
Chris's simple script above works fine for me running OX10.3.8

However, Firefox/Mozilla applescript library lacks a "do javascript" command, which is very important. I 
have heard that more applescript commands existed in prior versions. Where are they now?

Also, why are the "SpyGlass" commands in the current applescript dictionary?

Updated

12 years ago
Blocks: 237584
Assignee: bross2 → nobody
QA Contact: general
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 608049
You need to log in before you can comment on or make changes to this bug.