event.screenY value is inverse of correct value

RESOLVED FIXED in Camino1.0

Status

Camino Graveyard
General
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: Sebastian Winkler, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

({dom0, testcase})

unspecified
Camino1.0
PowerPC
Mac OS X
dom0, testcase

Details

Attachments

(1 attachment)

586 bytes, application/xhtml+xml
Details
(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021104 Chimera/0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021104 Chimera/0.6

The screenY value of the Event Object recorded by Camino is inverse to the
correct value (i.e. higher values towards the top of the screen and lower values
towards the screen bottom)

This bug is related to bug 165607
(http://bugzilla.mozilla.org/show_bug.cgi?id=165607) which has already been
fixed and is apparently caused by the PostScript/PDF-based nature of MacOSX's
native coordinate system.

Reproducible: Always
Steps to Reproduce:
<input type="button" value="show event Y-position" onClick="alert(event.screenY)" >

Comment 1

14 years ago
Confirmed using Camino/2004-02-29-08. It works fine using Mozilla
2004-03-14-05-trunk and FireFox, so Camino only.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: dom0, testcase
Summary: event screenY coordinate is inverse → event.screenY value is inverse of correct value

Comment 2

14 years ago
Created attachment 144207 [details]
XHTML testcase

Comment 3

14 years ago
What is the version of OS currently used?
When it is the problem which occurs only by 10.3.x, does it depend with bug 224213?

Comment 4

14 years ago
My comment 1 was using 10.2.8.

Comment 5

14 years ago
This problem was reproduced although I was using 10.3.3.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; ja-JP; rv:1.7b) Gecko/20040317
Camino/0.7+
(Assignee)

Updated

14 years ago
Target Milestone: --- → Camino1.0

Comment 6

13 years ago
Yeah, fixed.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 7

13 years ago
(...by Bug 281470.)
You need to log in before you can comment on or make changes to this bug.