Status

Thunderbird
Mail Window Front End
--
enhancement
RESOLVED DUPLICATE of bug 328795
14 years ago
12 years ago

People

(Reporter: Miles Libbey, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040316
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040316

Currently, type ahead find does not work in Thunderbird 0.5, whereas it does
work in the Mozilla Mail (1.6 and 1.7B at least).  

Reproducible: Always
Steps to Reproduce:

Comment 1

14 years ago
I'll confirm this on the basis that it is a bug, but it's because thunderbird
doesn't build the extension.  Do we want this in default builds?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

14 years ago
*** Bug 239216 has been marked as a duplicate of this bug. ***

Comment 3

14 years ago
If the feature is in Mozilla / Firefox I see no point why it shouldn't be
implemented in TB as well.  It increases productivity a lot, especially for
command-line people.  Again, I don't understand why such a great feature of the
companion products is not there in TB.

On the other hand, of course that some of the keyboard shortcuts (eg for
expanding/collapsing threads) would have to be redefined, but I definitely think
it's worth it.

Comment 4

14 years ago
i miss this feature in thunderbird. would enabling classic mozilla type-ahead
behavior (ie, must enter "/" to call search) fix incompatibility with keyboard
shortcuts?

very useful to have type-ahead when getting long emails (specifically i used it
to find keywords in journal tables of contents that are sent biweekly) and would
be nice to have it back.

Comment 5

13 years ago
Using toolkit's typeaheadfind is required in order to use Firefox's find bar. 
However, the find bar isn't just for the main window.  Firefox Help uses the
find bar, and while Help will be hacked to use the old-style find in Thunderbird
when bug 253334 is fixed, it *won't* be pretty.  Adding in typeaheadfind would
let us nix any such hacks.

The find bar is also currently hacked away in viewsource, which is used for
looking at message source code.  Adding typeaheadfind would fix that situation
as well.

Comment 6

13 years ago
*** Bug 285636 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 7

12 years ago
Looks like this bug was duplicated by the mozilla team and fixed as 328795.

*** This bug has been marked as a duplicate of 328795 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.