The tools >> Translate function doesn't work on any web-site

RESOLVED WORKSFORME

Status

SeaMonkey
UI Design
RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: Vasiliy, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316

The tools >> Translate function doesn't work on any web-site. F.e.,
http://web-gamer.com - 1/2 english, 1/2 russian. Try to translate the page
through Tools >> Translate Page - it won't work at all.

Reproducible: Always
Steps to Reproduce:
1. Go to, f. e., http://vip-ip.net, it's a good example of a russian web-page;
2. Click Tools >> Translate Page button in the top menu bar
3. Nothing happens.

Actual Results:  
Nothing happens, but translation should happen.

Expected Results:  
Put the appropriate code on mnuTranslatepage_Click()
=)

Comment 1

15 years ago
I too see that "nothing happens" - i get the top google frame, but the frame
where a translation should appear remains blank, page seemingly keeps loading,
and cursor remains an hourglass. However, the google translator doesn't yet
speak russian. Dup of bug 236020?
well, I see that nothing happens at all. js console says:
Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIPrefBranch.getComplexValue]"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://navigator/content/navigator.js :: Translate :: line 750"  data: no]

(win2k, 2004031616)
Assignee: general → guifeatures
Component: Browser-General → XP Apps: GUI Features
probably caused by bug 234087

hmm. about:config says:
browser.translation.service default string
http://translate.google.com/translate?prev=/language_tools&u=
Status: UNCONFIRMED → NEW
Depends on: 234087
Ever confirmed: true
oh, right, about:config is uselsss, it will show the "real" value for localized
prefs. grrr.

Comment 5

15 years ago
I believe this is related to <a href="show_bug.cgi?id=238029">238029</a>. There
seems to be something wrong with some of the .jar files or how they're processed.

Comment 6

15 years ago
OK, so xpfe/bootstrap/browser-prefs.js has the right prefs, but
dist/bin/defaults/pref/browser-prefs.js does not...

Comment 7

15 years ago
Hmm, I wonder about that...
Shouldn't the xpfe/bootstrap version be automatically written to the dist/bin
version?

BTW, what is the "wrong" value that is in there? My changes shouldn't have any
noticeable problems for people that have a browser-prefs.js from before my
changes (i.e. with the URL set directly in that file), I thought...

Comment 8

15 years ago
No, as soon as you have a pref localized string then the default value must be a
locale url.

Comment 9

14 years ago
You click the translate in the tools menu and it doesn't do anything. This
worked in the BETA version, but hasn't worked in either of the RC versions. 

Comment 10

14 years ago
The error report in RC2 has now changed slightly:

translate gives:
Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIPrefBranch.getComplexValue]"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://navigator/content/navigator.js :: Translate :: line 759"  data: no]

also, while testing, mozilla completely locked up the first time I clicked translate

Comment 11

14 years ago
1.7rc3 still not working - error is same as rc2

Comment 12

14 years ago
Same here in both Windows 2000 and XP Professional SP1 (both OS' have all
updates). I upgraded from v1.6 which didn't have this problem. Is there a
workaround?

Comment 13

14 years ago
Using 1.7 release, translate is still broken with same page 759 error

Comment 14

14 years ago
(In reply to comment #12)
> Same here in both Windows 2000 and XP Professional SP1 (both OS' have all
> updates). I upgraded from v1.6 which didn't have this problem. Is there a
> workaround?

Oops, I forgot to mention that I was using v1.7 final.
Product: Core → Mozilla Application Suite

Comment 15

13 years ago
See bug 296844 for possible cause.

Comment 16

13 years ago
works OK now in 1.7.12

Comment 17

13 years ago
Same here. :)

Updated

13 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.