Sidebar size gets changed when uncollapsing it

RESOLVED DUPLICATE of bug 23858

Status

--
minor
RESOLVED DUPLICATE of bug 23858
15 years ago
14 years ago

People

(Reporter: travisgevans, Unassigned)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7b) Gecko/20040316 MultiZilla/1.6.2.0c
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7b) Gecko/20040316 MultiZilla/1.6.2.0c

When the Sidebar is reopened by clicking the handle on the frame (after being
collapsed), and the mouse is not held prefectly steady before the mouse button
is released, the Sidebar forgets the current size when it appears and changes to
an insanely small size.


Reproducible: Always
Steps to Reproduce:
1. Display the Sidebar.
2. Collapse it by clicking the grippy handle.
3. Click the handle to reopen it, but at the point where the mouse button is
held down, move the mouse just a pixel or two before releasing it.


Actual Results:  
The sidebar resizes to a very small size.


Expected Results:  
The Sidebar should only resize when the resizing portions of the frame are dragged.


It appears that when the mouse is moved, it counts as having dragged the frame
(even though initally the frame may not even be near the mouse pointer when the
Sidebar appears), which causes it to start resizing. IMO, this requires mouse
movements that are far too precise (it's difficult sometimes not to move the
mouse at least a pixel or two when clicking an object).

The Sidebar shouldn't resize at all when the handle is clicked, even if the
mouse is moved a little.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 23858 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.