Inconsistent drop down list layout upon changing display size

RESOLVED DUPLICATE of bug 62384

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 62384
14 years ago
14 years ago

People

(Reporter: Saurabh Gupta, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

The layout of drop down lists in forms within a webpage show inconsistent
behavior when reverting to default size from a larger display size.

Reproducible: Always
Steps to Reproduce:
1. Go to the webpage http://cgi.411web.com/homebound/v2/
2. Navigate to any other link from this page
3. Increase the display size of that page to maximum using CTRL++
4. Navigate back to http://cgi.411web.com/homebound/v2/ keeping that size
5. Now decrease the size using CTRL-- and observe the drop down lists and their
layouts (refer attachments)


Actual Results:  
Upon reverting to normal display size the drop down lists retain a larger
(inconsistent) size whereas the other input fields and text shows normal behavior.
(refer attachments)


Expected Results:  
Upon returning to the normal display size, all the fields should also return to
the normal sizes (consistent).

Follow Up Tests
---------------
1. As a follow up test, I altered the display settings from
Tools->Options->Fonts & Colors. Upon setting all the numeric options to maximum,
and following the same navigation procedure of the webpages listed above, the
same inconsistency is visible.
2. I also replicated the same procedure for webpages without input fields (just
text) and in certain cases the test appeared smudged and overlapping.
3. Another inconsistency discovered while using the CTRL-- option was that after
the display size decreases to the minimum, a further use of CTRL-- will increase
the text size, which is an opposite action to what is intended by CTRL--.

Importance of the bug
---------------------
1. Firefox claims "Simplified user interface" as one of its highlighting
features (refer http://www.mozilla.org/products/firefox/why/), however an
inconsistency in the layout (handling layouts) is in direct conflict with this
statement. 
2. Size manipulation of Firefox is certainly better than a few other browsers,
however this added benefit leading to UI issue such as that of smudging text and
inconsistency in handling certain input fields, is something that can be an
integrity issue for the browser.
(Reporter)

Comment 1

14 years ago
Created attachment 144708 [details]
Example 1

This snapshot depicts what is indicated in the bug report
(http://cgi.411web.com/homebound/v2/)
(Reporter)

Comment 2

14 years ago
Created attachment 144709 [details]
Example2

This snapshot is yet another example where the drop down lists are mishandled.

Comment 3

14 years ago
*** Bug 238581 has been marked as a duplicate of this bug. ***

Comment 4

14 years ago
This is a dup of bug 62384.  One of your "followup tests" should have been filed
separately from this bug, but it's a dup of bug 53995 anyway.

*** This bug has been marked as a duplicate of 62384 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.