Firefox command line -width -height broken

RESOLVED DUPLICATE of bug 50201

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 50201
14 years ago
4 years ago

People

(Reporter: Bryce Mozilla Nesbitt, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040212 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040212 Firefox/0.8

type "./firefox -h" and several potentially userfull command line options will
be shown, including -width and -height.  They don't, however, work.

I'm trying to run firefox without a window manager, for a Kiosk application. 
This will work fine if firefox can be told to open a specific size window, and
drop right into fullscreen mode (F11).

Reproducible: Always
Steps to Reproduce:
1. run "firefox -h"
2. run "firefox -width 1024 -height 768"
3. run "firefox -width 1024 -height 768 -fullscreen"

Actual Results:  
firefox opens with a different size window.

Expected Results:  
It would be great for firefox to offer command line options for fullscreen mode,
and for width and height of the initial window.

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

14 years ago
Workaround:  edit localstore.rdf in the profile directory:

 <RDF:Description RDF:about="chrome://global/content/viewSource.xul#main-window"
                   sizemode="normal"
                   height="768"
                   width="1024"
                   screenX="0"
                   screenY="0" />

Comment 2

14 years ago
chrome://global/content/viewSource.xul#main-window
should probably be changed to
chrome://browser/content/browser.xul#main-window

E.g.

 <RDF:Description RDF:about="chrome://browser/content/browser.xul#main-window"
                   sizemode="normal"
                   height="768"
                   width="1024"
                   screenX="0"
                   screenY="0" />

Updated

14 years ago
Whiteboard: DUPEME

Updated

14 years ago
Blocks: 269140

Comment 3

13 years ago
From #269140:

The width and heigt options do work if i comment out LoadSizeFromXUL(); on line
936 of mozilla/xpfe/appshell/src/nsXULWindow.cpp

Comment 4

13 years ago
Bryce: Bug 226034 is about -fullscreen, which is a slightly different problem
than the other flags you mentioned here.
Summary: Firefox command line -width -height broken. No -fullscreen for operation without window manager → Firefox command line -width -height broken

Comment 5

13 years ago
*** Bug 269140 has been marked as a duplicate of this bug. ***

Updated

13 years ago
No longer blocks: 269140

Comment 6

13 years ago

*** This bug has been marked as a duplicate of 50201 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 7

5 years ago
Why does it say "resolved"???? I can't get it to work at all in windows 7.

Comment 8

5 years ago
Works for me with 2013-05-20-03-12-30-mozilla-central-firefox-24.0a1.en-US.linux-x86_64.

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.