Last Comment Bug 50201 - -width and -height options ignored
: -width and -height options ignored
Status: RESOLVED WORKSFORME
bugday0420
: helpwanted
Product: Toolkit
Classification: Components
Component: Startup and Profile System (show other bugs)
: Trunk
: All All
: -- normal with 20 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 238607 323128 352328 364729 388419 (view as bug list)
Depends on: 20573
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-24 12:58 PDT by sairuh (rarely reading bugmail)
Modified: 2012-10-03 12:43 PDT (History)
30 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description sairuh (rarely reading bugmail) 2000-08-24 12:58:53 PDT
couldn't find an existing [open] bug on this, so...

i've tried the following command-line options, all of which do nothing to change 
the size of the browser window (which maintains the same size from its previous 
session):

mozilla -height 200
mozilla -width 200
mozilla -height 200 -width 200

am using today's 2000.08.24.08 opt bits on Win98. i don't have access to the 
linux bits today --timeless, pavlov or jrgm, could you see whether these options 
work at all on linux? my guess is that they won't, but ya never know.

so, like if these commands aren't supposed to work as i've issued 'em, pls let 
me know if

1. they ain't implemented. then we should either implement 'em, or pull 'em out.
2. i'm somehow issuing the commands incorrectly. strange, but lemme know the 
correct way. thx!
Comment 1 sairuh (rarely reading bugmail) 2000-08-24 12:59:44 PDT
with gramps on sabbatical, who should be the lucky owner of this bug?
Comment 2 timeless 2000-08-24 14:14:12 PDT
Solaris8Intel build from tuesday's tip doesn't seem to use these params either.
Comment 3 sairuh (rarely reading bugmail) 2000-08-25 17:13:00 PDT
thx, timeless.
Comment 4 verah (gone) 2000-08-29 12:52:05 PDT
Nav triage team: [nsbeta3-], leaving assigned to Don for the time being.
Comment 5 sairuh (rarely reading bugmail) 2000-08-31 16:34:13 PDT
methinks the fix to this might be dependent on fixes for bug 20573...
Comment 6 Viswanath Ramachandran 2000-12-06 11:29:06 PST
Since Don has left, Vishy is taking his bugs in bulk, pending reassignment.
thanks,
	Vishy
Comment 7 Marcia Knous [:marcia - use ni] 2000-12-19 17:02:57 PST
Netscape Nav triage team: this is not a Netscape beta stopper.
Comment 8 Colin Phillips 2001-02-20 08:15:44 PST
Could this be implemented anytime soon?  The company I work for is planning to
use mozilla & XUL under Linux for our core borwser component, and it would be
very desirable to have geometry ability from the command line.
Comment 9 Blake Ross 2001-02-20 17:47:18 PST
-> law
Comment 10 Paul Chen 2001-03-20 10:38:12 PST
Marking nsbeta1- bugs as future to get off the radar.
Comment 11 Peter Weilbacher 2003-12-01 10:18:06 PST
Since this does not seem to get resolved soon, could someone please change the
reference webpage
http://www.mozilla.org/quality/browser/front-end/testcases/cmd-line/
accordingly, i.e. deleted the lines involving -height and -width? (And on that
occasion rename Win32 in the Unix/Linux section to Unix/Linux?)
Or should I open a new bug for this?
Comment 12 Brian 2004-08-23 11:46:43 PDT
It's interesting to note that in Debian, the -width and -height arguments
work in the 1.0.0 package and in the 1.5-3 package, but not in the 1.6-5
package.
Comment 13 Felix Miata 2005-01-17 07:35:06 PST
This bug applies to latest 1.7.6 on WinXP and Linux GTK2+XFT trunk as well.

Note that the following:

mozilla -P profilename -height 768 -width 1024 -browser http://www.google.com

will bring up a Google window 1024px wide and 768px high, but it will be
chromeless in which no keyboard functions for controls, such as ctrl++, ctrl+- &
ctrl+h, do anything at all.
Comment 14 Felix Miata 2005-01-17 07:36:14 PST
*** Bug 238607 has been marked as a duplicate of this bug. ***
Comment 15 steve rader 2005-10-28 03:11:25 PDT
fwiw, a hack to force mozilla to have a specifc geometry 
(via a mozilla/init.d pluggable shell script) can be find 
at ftp://noc.hep.wisc.edu/pub/src/mozilla
Comment 16 Magnus Melin 2006-02-12 07:26:11 PST
*** Bug 323128 has been marked as a duplicate of this bug. ***
Comment 17 nts 2006-07-09 06:03:39 PDT
This bug exists in the Firefox/1.5.0.4 (OpenSuSE Linux):

Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-GB; rv:1.8.0.4) Gecko/20060527 SUSE/1.5.0.4-1.3 Firefox/1.5.0.4

My tests show that MOST commandline options are ignored, -width, -height, -ProfileManager, -P <profile>.  This occurs when calling firefix and also when calling firefox-bin directly.

When firefox exits, the following content gets written to localstore.rdf :

<RDF:Description RDF:about="chrome://browser/content/browser.xul#main-window"
                   width="861"
                   height="946"
                   screenX="411"
                   screenY="0"
                   sizemode="maximized" />

(I hope I copied the correct portion out of the file!)

This is irrespective of the current window geometry.

Hope this helps,

nts.
Comment 18 nts 2006-08-24 02:04:48 PDT
This is, at least in part, related to Bugzilla Bug 317903.  There it is explained that profile commandline options are ignored unless the environment variable MOZ_NO_REMOTE is set to 1 (tcsh: "setenv MOZ_NO_REMOTE 1", bash: "export MOZ_NO_REMOTE=1").  This might also affect other commandline options.

Setting MOZ_NO_REMOTE to 1 has helped in my case to display and enable profiles.

Personally, I think that a warning message should appear to explain that commandline options were ignored and what to do so that they are not!

nts.
Comment 19 Nick Thomas [:nthomas] 2006-09-12 03:59:33 PDT
*** Bug 352328 has been marked as a duplicate of this bug. ***
Comment 20 Magnus Melin 2006-12-26 12:29:29 PST
*** Bug 364729 has been marked as a duplicate of this bug. ***
Comment 21 Adam Guthrie 2007-07-17 11:49:50 PDT
*** Bug 388419 has been marked as a duplicate of this bug. ***
Comment 22 Brad Langhorst 2008-01-22 12:03:27 PST
MOZ_NO_REMOTE=1 has no effect
MOZ_NO_REMOTE=1 firefox -height 500 -width 400

has no effect.
Comment 23 Hans Deragon 2008-08-15 06:36:59 PDT
I confirm that:

  export MOZ_NO_REMOTE=1
  firefox -height 800 -width  600 

...has not effect.

Build identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008072820 Firefox/3.0.1
Comment 24 Magnus Melin 2008-08-15 23:36:43 PDT
per bug 444319, turning this into a seamonkey bug.
Comment 25 karl berry 2009-05-07 11:27:12 PDT
suggest combining with #20573 per discussion there.
Comment 26 Jim Rees 2010-10-18 17:24:13 PDT
Has this been fixed? It's working for me now, but is undocumented as far as I can tell, and doesn't show up in "firefox --help." So is it working by accident or by design?
Comment 27 Daniël van Eeden 2010-10-19 00:58:57 PDT
I can confirm that it is working in Mozilla Firefox 4.0b6 and that it does not show up in the -help output. This is on a 32-bit Linux system.
Comment 28 Magnus Melin 2012-10-03 12:38:55 PDT
Yeah they aren't shown anywhere anymore, so no reason to believe they would work either. 
WFM.
Comment 29 Magnus Melin 2012-10-03 12:43:46 PDT
Whops, indeed they are working. Just not documented.

Note You need to log in before you can comment on or make changes to this bug.