If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Site icon makes bookmark icon and text go away in tree widget

NEW
Assigned to

Status

()

Core
XUL
14 years ago
9 years ago

People

(Reporter: Kai de Leeuw, Assigned: janv)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040316

I have bookmarked http://www.teliamobile.se with the following preferences set:
browser.chrome.load_toolbar_icons	2
browser.chrome.favicons			true

This leads to the text of the bookmark and the site icon not to show at all in
the tree widget. Instead it seems like there is a white box cover the icon and
text. I will attach how it looks with two screenshots of the bookmark item not
selected and selected.

Reproducible: Always
Steps to Reproduce:
1. Set the preferences according to the above description
2. Bookmark http://www.teliamobile.se  
3. Look at the bookmark in for instance Bookmark Sidebar or Manage Bookmarks

Actual Results:  
Site icon and text not visible.

Expected Results:  
Site icon and text visible.

Also tested on a clean profile and install with Classic, same error there.
(Reporter)

Comment 1

14 years ago
Created attachment 144912 [details]
This shows the bookmark in the bookmark sidebar
(Reporter)

Comment 2

14 years ago
Created attachment 144913 [details]
This shows the bookmark in the bookmark sidebar in a selected state
(Reporter)

Updated

14 years ago
Attachment #144913 - Attachment is obsolete: true
(Reporter)

Comment 3

14 years ago
Created attachment 144914 [details]
This shows the bookmark in the bookmark sidebar in a selected state
(Assignee)

Comment 4

14 years ago
The favicon is just too big and there's no image resize support in the tree
widget yet.
Status: UNCONFIRMED → NEW
Depends on: 199209
Ever confirmed: true
(Reporter)

Comment 5

14 years ago
Aaah yes, now I understand why it behaves like this. 

The address http://www.teliamobile.se/favicon.ico doesn't really point to an
icon but an error message that is a GIF image, and that is why it shows that
picture as a site icon. And I who searched and searched for a <link> tag or the
favicon.ico file.

Updated

9 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: shrir → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.