1.7b topcrash [@ nsDownloadManager::Observe]

RESOLVED DUPLICATE of bug 206337

Status

SeaMonkey
Download & File Handling
RESOLVED DUPLICATE of bug 206337
14 years ago
14 years ago

People

(Reporter: chris hofmann, Unassigned)

Tracking

({topcrash})

Trunk
x86
Windows XP
topcrash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

14 years ago
looks like someone has found a way to hose the download manager in 1.7b

Rank    StackSignature    Count  

13   nsDownloadManager::Observe   24 

 
 	Source File :
c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/xpfe/components/download-manager/src/nsDownloadManager.cpp
line : 880
 
====================================================================================================
     Count   Offset    Real Signature
[ 10   nsDownloadManager::Observe dc724c05 - nsDownloadManager::Observe ]
[ 5   nsDownloadManager::Observe 5fc208d5 - nsDownloadManager::Observe ]
[ 4   nsDownloadManager::Observe 49b99ad8 - nsDownloadManager::Observe ]
[ 2   nsDownloadManager::Observe 7fe98028 - nsDownloadManager::Observe ]
[ 2   nsDownloadManager::Observe 775e3da0 - nsDownloadManager::Observe ]
[ 1   nsDownloadManager::Observe 6c7630d8 - nsDownloadManager::Observe ]
 
     Crash date range: 22-MAR-04 to 26-MAR-04
     Min/Max Seconds since last crash: 1 - 120027
     Min/Max Runtime: 543 - 353374
 
     Count   Platform List 
     21   [Windows NT 5.1 build 2600]   
     3   [Windows NT 5.0 build 2195]   
 
     Count   Build Id List 
     24   2004031615
 
     No of Unique Users        10
 
 Stack trace(Frame) 

	 nsDownloadManager::Observe
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/xpfe/components/download-manager/src/nsDownloadManager.cpp
 line 880] 
	 nsObserverService::NotifyObservers
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsObserverService.cpp
 line 210] 
	 nsProfile::ShutDownCurrentProfile
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/profile/src/nsProfile.cpp
 line 1359] 
	 DoOnShutdown
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp
 line 804] 
	 main
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp
 line 1717] 
	 WinMain
[c:/builds/tinderbox/Mozilla1.7b/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp
 line 1734] 
	 WinMainCRTStartup()  
	 kernel32.dll + 0x214c7 (0x77e614c7)   
 
     (5854)	Comments: Everytime I close Mozilla  I get error message
"Mozilla.exe has performed an illegal operation and needs to close."  Also I can
no save files.  Download Manager does not open.
     (5300)	Comments: Can't open Download Manager.  Can't save files.

*** This bug has been marked as a duplicate of 206337 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
Crash Signature: [@ nsDownloadManager::Observe]
You need to log in before you can comment on or make changes to this bug.