Closed Bug 238446 Opened 16 years ago Closed 16 years ago

Mozilla 1.7 talkback top 20 analysis (M17beta, M17rc1)

Categories

(Core Graveyard :: Talkback Client, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: chofmann, Assigned: jigneshjpatel)

References

()

Details

Attachments

(3 files, 2 obsolete files)

make sure we have run though the top 20 crashers and have bugs on file...  jay
can use help where people want to pitch in.   until we get reports published it
going to be a bit quirky, but we can publish reports and comments here until the
scripts and tie-ins to bugzilla  I'll attach something here soon.
helpers,  be sure to check for existing bugs and just add the topcrash keyword
to those, before opening new bugs with the topcrash keyword...

thanks

 Total blackboxes in this sample:      640
 Total unique users:      436
 MTBF For these builds is estimated at 4.349692 hours,
 based on 640 reports and 2783.803056 hours of user testing
 from testers that have crashed and reported problems.
  (dev. builds tend to have low MTBF)

 Top crashes 

Count  Area      Bug    Status   Resolution   Owner   Milestone    Last Changed 
(1) 204  TableBackgroundPainter::TableBackgroundData::Destroy  
(2) 28  nsJSContext::DOMBranchCallback  

already bugs on file for the top 2 


(3) 13  ntdll.dll  
(4) 13  nsXULDocument::RemoveSubtreeFromDocument  
(5) 13  MSVCRT.DLL  
(6) 13  MISSING-SIGNATURE  
(7) 13  GetDocumentFromScriptContext  
(8) 11  0x00000000  
(9) 9  nsLDAPConnection::InvokeMessageCallback  

  think we have one on this too.

(10) 9  IsCanvasFrame  
(11) 8  nsLineLayout::ReflowFrame  
(12) 8  nsCSSFrameConstructor::FindFrameWithContent  
(13) 8  msvcrt.dll  
(14) 7  LiteralImpl::~LiteralImpl  
(15) 6  nsTableRowFrame::SetContinuousBCBorderWidth  
(16) 6  nsDownloadManager::Observe  
(17) 6  nsCSubstring::SetCapacity  
(18) 6  jvm.dll  
(19) 5  nsXULElement::HandleDOMEvent  
(20) 5  RDF.DLL  

Flags: blocking1.7+
(1) 204  TableBackgroundPainter::TableBackgroundData::Destroy   
http://bugzilla.mozilla.org/show_bug.cgi?id=237421

(2) 28  nsJSContext::DOMBranchCallback 
http://bugzilla.mozilla.org/show_bug.cgi?id=238218
(4) 13  nsXULDocument::RemoveSubtreeFromDocument  
http://bugzilla.mozilla.org/show_bug.cgi?id=228774
(7) 13  GetDocumentFromScriptContext    might need some love
(9) 9  nsLDAPConnection::InvokeMessageCallback   -> bug 230211
bottom 10 and the rest need more analysis I think
Depends on: 228774, 230211, 237421, 238218
Attachment #144621 - Attachment mime type: application/octet-stream → application/zip
(17) 6  nsCSubstring::SetCapacity bug 238219
Depends on: 238219
for that last one we should also pull together deCOMtamination folks and see if
there are more areas to check and more bugs to file to be more defensive in
deCOMtamination changes...
Depends on: 238454
Summary: 1.6b talkback top 20 analysis → 1.7b talkback top 20 analysis
Is there any url for the nsTableRowFrame::SetContinuousBCBorderWidth  crash?
put some data for nsTableRowFrame::SetContinuousBCBorderWidth in bug 238537
Depends on: 238537
Depends on: 238914
New ranking from the report from this morning with more data....

Count  Area      Bug    Status   Resolution   Owner   Milestone    Last Changed 
(1) 434  TableBackgroundPainter::TableBackgroundData::Destroy  
(2) 137  nsJSContext::DOMBranchCallback  
(3) 55  MSVCRT.DLL  
(4) 48  ntdll.dll  
(5) 48  0x00000000  
(6) 33  MISSING-SIGNATURE  

(7) 27  secmod_DecodeData  
   --> filed bug 238914 http://bugzilla.mozilla.org/show_bug.cgi?id=238914

(8) 27  nsXULElement::HandleDOMEvent  
(9) 26  LiteralImpl::~LiteralImpl  
(10) 26  GetDocumentFromScriptContext  
(11) 24  nsLDAPConnection::RemovePendingOperation  
(12) 24  nsLDAPConnection::InvokeMessageCallback  
(13) 24  nsDownloadManager::Observe  
(14) 23  msvcrt.dll  
(15) 22  nsXULDocument::RemoveSubtreeFromDocument  
(16) 22  jvm.dll  
(17) 20  nsLineLayout::ReflowFrame  
(18) 18  nsImapProtocol::HandleMessageDownLoadLine  
(19) 18  nsCSSFrameConstructor::FindFrameWithContent  
(20) 16  nsTableRowFrame::SetContinuousBCBorderWidth  

No longer depends on: 238914
Depends on: 238917
Depends on: 206337
Depends on: 238906
Depends on: 238914
Depends on: 239038
I've been tracking topcrashers on a spreadsheet as I look at Talkback data for
the latest milestones.	This table shows the ranking by date and includes any
bug info that I have found for that crash.

If people find it useful, I can update the attachment once a week.
Updated topcrash list
Attachment #147259 - Attachment is obsolete: true
Summary: 1.7b talkback top 20 analysis → Mozilla 1.7 talkback top 20 analysis (M17beta, M17rc1)
Attachment #148457 - Attachment is obsolete: true
all dependencies are resolved. Do we need to add more dependencies or resolve
this bug?
I think we started adding dependencies early, but since the topcrash rankings
change often, I haven't added any new bugs.  

Instead, I have been updating the attachments with the latest topcrash table so
we can keep track of topcrash fixes with the 1.7 branch.  We can leave it open
so people can look at the table if they want to see what bugs need to be looked
at, which ones have been fixed and catch possible regressions.
mark this one fixed now..
Status: NEW → RESOLVED
Closed: 16 years ago
Flags: blocking1.7+ → blocking1.7-
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.