Closed Bug 238992 Opened 16 years ago Closed 16 years ago

firefox -remote option doesn't work on MacOS X

Categories

(Firefox :: General, defect)

PowerPC
macOS
defect
Not set

Tracking

()

VERIFIED INVALID

People

(Reporter: zorin, Assigned: bugzilla)

References

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040206 FireFox/0.8
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040206 FireFox/0.8

The -remote option doesn't work on MacOS X. The browser just tries to startup as
another instance, and displays the "choose profile" dialog. It works fine on Linux.

Reproducible: Always
Steps to Reproduce:
Try to run something like:

/Applications/Firefox.app/Contents/MacOS/firefox -remote 'openURL(whatever)'


Actual Results:  
Another full instance of Firefox launches.

Expected Results:  
Should have followed the -remote directive just like the Linux version does.

I ran a "strings" and noticed that -remote wasn't present in the firefox-bin in
the MacOS X build, but IS present in the Linux build. Did this somehow get
#ifdef'ed out on MacOS?
I don't think xremote is enabled on OS X for anything from Mozilla
QA Contact: mconnor
-remote is specific to Unix builds.  OS X handles processes and instances
differently than Linux, so remote is irrelevant.

-> INVALID, this functionality is not used on the platform in question.
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → INVALID
MacOS X <u>is</u> a Un$x build! :-) 
 
I have the same problem on Firefox 1.0, MacOS X 10.3. 
 
If there is no way to launch a new browser tab/window from the command line 
while an existing session is open (I have not found one) then this should be 
fixed with something similar (preferably identical) to the -remote facility. If 
there is a way to launch new windows/tabs in the same session from the command 
line then this could be added to the FAQ or similar. 
 
Is it better to reopen this bug, or file a new one? Or am I missing something 
here that should be obvious? 
*** Bug 236658 has been marked as a duplicate of this bug. ***
Use appleevents.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.