horizontal scrollbar is rendered incorrectly

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
15 years ago
4 years ago

People

(Reporter: bloodnok, Unassigned)

Tracking

({platform-parity, polish})

Trunk
PowerPC
Mac OS X
platform-parity, polish

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040316
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040316

the background image for a horizontal scrollbar, the image showing the extent of
the not-visible window isn't rendered. rather than a border and a grey
background, there's just white. it looks unsightly and it could possibly result
in confusion.

seen on a movable type blog entry page - this is on my server and not accessible
to outsiders, but can probably be seen on any moveable type site.

Reproducible: Always
Steps to Reproduce:
not applicable
(Reporter)

Comment 1

15 years ago
this rendering error is still present in rv 1.7rc1. it's annoying enough that
i'm sticking with 1.6, which hasn't the error.

Comment 2

15 years ago
dennis, please either attach your HTML source or provide an accessible URL that
demonstrates the problem.
(Reporter)

Comment 3

15 years ago
Created attachment 147421 [details]
contains an example page from my blog editor

this example more or less renders the same way as the live application. it
definitely shows the horizontal scrollbar error. hope this helps find a fix!

Comment 4

14 years ago
Reporter, I looked at the examples you attached, but couldn't see any <hr> tag
that was obviously rendered incorrectly. Please could you be more specific about
where on the page its wrong. (Ideally attach a screenshot with the errant <hr>
tag highlighted).
(Reporter)

Comment 5

14 years ago
Created attachment 150379 [details]
a mac/pdf screencapture showing bug still present in 1.7rc3.

this is still unfixed as of 1.7rc3 (and i stupidly contributed another $50...)
(Reporter)

Comment 6

14 years ago
(In reply to comment #4)
> Reporter, I looked at the examples you attached, but couldn't see any <hr> tag
> that was obviously rendered incorrectly. Please could you be more specific about
> where on the page its wrong. (Ideally attach a screenshot with the errant <hr>
> tag highlighted).

please note: it's not the <hr/> tag, it's the scrollbar in a a textbox that's at
fault. see the previously attached screenshot showing a correct vertical
scrollbar and an incorrect horizontal scrollbar.

by entering an excessively long string (i just held down "xxxxx..." until the
scrollbar appeared and kept going to see that it's rendered incorrectly) in this
bugzilla textbox, i saw the same incorrect horizontal scrollbar. it's definitely
a mozilla rendering bug and not a movabletype css issue...

Comment 7

14 years ago
just to clarify: the issue seen in the attachment to comment 5
is not limited to textarea fields, but appears with any modern
theme horizontal scrollbar (main browser window, compose mail,
etc.), every time.

for another aspect of the same issue (html rendering leftovers
in the scrollbar area) see bug 238982.
(Reporter)

Comment 8

14 years ago
Created attachment 151073 [details]
png screenshot of still busted scrollbars...

what a disappointment. it's still busted in Mozilla/5.0 (Macintosh; U; PPC Mac
OS X Mach-O; en-US; rv:1.7) Gecko/20040616. shan't be upgrading the OSX
machine...
(Reporter)

Updated

14 years ago
Attachment #147421 - Attachment is obsolete: true
Attachment #150379 - Attachment is obsolete: true

Comment 9

14 years ago
Please attach a small testcase that demonstrates the problem if possible.
Assignee: jdunn → sfraser
Severity: trivial → normal
Status: UNCONFIRMED → NEW
Component: Image: GFX → GFX: Mac
Ever confirmed: true
Keywords: polish, pp
(Reporter)

Comment 10

14 years ago
Steps to reproduce:

1) make sure your mac is running mozilla 1.7.x with the modern theme (didn't
test the classic theme because i don't use the classic theme)
2) log onto bugzilla.mozilla.org
3) edit bug http://bugzilla.mozilla.org/show_bug.cgi?id=239035
4) enter a long string of text into the "additional comments" text box - one
without any white space so that it doesn't wrap. for example, a long url such as
http://www.nytimes.com/2004/07/23/opinion/23krug.html?hp=&pagewanted=print&position=
5) observe the appearance of the horizontal scrollbar
6) fix the problem

Comment 11

14 years ago
confirming presence of bug, using Mozilla/5.0 (Windows; U; Windows NT 5.1;
en-US; rv:1.7.2) Gecko/20040803, modern theme.

i notice this on viewing source most often. horizontal scrollbar does not have
proper styling - no scroll arrows, no little "lines" on scroll widget. vertical
scrollbar is OK.

horizontal scrollbar area seems to be colored incorrectly - either left blank
white, rendered a shade of gray that is not the same as horizontal scrollbar
background, or when viewing source, after alt-tabbing to another window and back
the scrollbar background turns solid black.

Comment 12

14 years ago
Created attachment 155832 [details]
broken scrollbar when viewing source, windows XP

added .png image to show broken scrollbars when viewing source. black
background is shown, as it appears after window regains focus. if scrollbar is
clicked on or moved black background reverts to a gray slightly darker than the
color used for vertical scrollbar background.

Comment 13

14 years ago
would like to add that this does not seem to be always reproducible in windows.
switching to classic theme, then restarting mozilla shows no problem. switching
back to modern and then restarting shows no problem. have tested this with both
text boxes and with view source on multiple pages.

windows issue might be a memory leak - i generally leave mozilla mail window
running all day, and only shut down the program completely when leaving for the
day. restarting mozilla (rather than the act of switching themes) might not be
the reason this stopped happening.

Comment 14

14 years ago
related to bug 238982, probaly caused by the same bug
Blocks: 238982
(Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707)

(In reply to comment #13)
> switching to classic theme, then restarting mozilla shows no problem. switching
> back to modern and then restarting shows no problem. have tested this with both
> text boxes and with view source on multiple pages.

Switching to classic mode and then back to modern does seem to solve this issue.
I've always used the modern theme (since 1.5) and I think the issue appeared
when I upgraded from 1.6 to 1.7 - the classic theme had never been used with 1.7.

This might be an issue with theme initialisation - is there something done to
the modern theme when it is switched to that isn't done when Mozilla is installed?
(Reporter)

Comment 16

14 years ago
this is still broken in release 1.7.5 "Mozilla/5.0 (Macintosh; U; PPC Mac OS X
Mach-O; en-US; rv:1.7.5) Gecko/20041217". tried the workaround (In reply to
comment #15) - it had no effect.

back to 1.6...

Comment 17

11 years ago
Also broken in SeaMonkey 1.1.1 Mac OS X 10.3.9.  Modern theme only; switching to Classic Theme solves the problem (for those like me who like Classic Theme).

Updated

10 years ago
Assignee: sfraser_bugs → joshmoz
(Assignee)

Updated

10 years ago
Product: Core → Core Graveyard

Updated

10 years ago
Assignee: joshmoz → nobody
This bug has been buried in the graveyard and has not been updated in over 5 years. It is probably safe to assume that it will never be fixed, so resolving as WONTFIX.

[Mass-change filter: graveyard-wontfix-2014-09-24]
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.