Closed Bug 239036 Opened 20 years ago Closed 20 years ago

Context Menus not compliant with Aqua standard GUI

Categories

(Firefox :: Menus, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 34572

People

(Reporter: needle, Assigned: kevin)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; ja-jp) AppleWebKit/124 (KHTML, like Gecko) Safari/125.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040327 Firefox/0.8.0+

The context menus in the current Mac Firefox behaves differently from standard Mac OS X contextual 
menus in the following ways:

a)The Shadow behind the context menu is too shallow. Aqua context menus have darker shadows.
b)The context menu is opaque. The slight transparency present in Aqua context menus is missing.
c)Clicking in the divider bar between items does not close the menu.
d)When invoked, the selection highlight does not flash.
e)When closing, the context menu does not fade away. It instead disappears immediately.

While functionally minor, these discrepancies detract from the user experience. It's getting more so as 
the rest of the UI improves (aquafies) - the non-native look and behavior of the context menus sticks 
out like a sore thumb. Cross-platform compatibility should not be an excuse for UIs with non-native 
looks and feels.

Reproducible: Always
Steps to Reproduce:
1. Open a context menu.
2. Click on the divider bar.
3. Select an item.
Actual Results:  
The menu does not close when the divider bar is clicked.
The selection highlight for the selected item did not flash.

Expected Results:  
The menu should have closed when the divider bar was clicked.
The selection highlight for the selected item should have flashed before the menu closed.
-> Kevin
Assignee: firefox → webmail
If this stuff can't or won't be fixed in the theme, then dup to Bug 34572.
Greg's right. There's no way to fix this in the theme. Let's hope bug #34572
will be seriously considered for 1.0mac.

*** This bug has been marked as a duplicate of 34572 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
No longer blocks: macmeta
QA Contact: bugzilla → menus
You need to log in before you can comment on or make changes to this bug.