Closed Bug 239072 Opened 16 years ago Closed Last year

Ctrl+Shift+C shortcut does not work for Czech QWERTY keyboard

Categories

(MailNews Core :: Localization, defect)

x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: jozef.chocholacek, Unassigned)

References

(Blocks 1 open bug)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

Mozilla Mail 1.6, Windows XP Profi SP1 (OEM from IBM)
Pressing Ctrl+Shift+C does not work for "Mark All Read" when Czech QWERTY
keyboard layout is enabled. For all my other layouts (Czech QWERTZ, English and
Slovak QWERTY) it works fine.

Reproducible: Always
Steps to Reproduce:
1. In Windows XP Control Panel, Local and language settings, add Czech language
(Èe¹tina) and Czech QWERTY (Èeské QWERTY) keyboard layout.
2. Select it by pressing Alt+Left_Shift (or your kb switch shortcut key) when in
Mozilla Mail window.
3. Select folder with new messages, press Ctrl+Shift+C - nothing happens.

Actual Results:  
Nothing.

Expected Results:  
All new messages are marked read.
Assignee: sspitzer → rchen
Component: Mail Window Front End → Localization
QA Contact: esther → marina
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20031007
The same bug occurs on my notebook (Windows XP SP1, OEM IBM).
Actually, all Ctrl+Shift+[key] shortcuts (in mail agent, browser) cease to work
when switching to Czech QWERTY keyboard layout.
Is anyone working on this? The bug is still present (Mozilla 1.7 Gecko/20040616).
Or does this have something to do with another bug that is getting fixed?
Same with 1.7 final/W2K.
Marking NEW.

Seth: Who could help with resolving this issue?
Assignee: rchen → nobody
QA Contact: marina
Aaron: Is this bug duplicate of bug 186789 (Ctrl+Shift+[0-9a-f] Shortcuts in
Mozilla conflict with ISO 14755 Input methods)?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Reporter please try Dean's Keyboard Test Page which is attachment 55849 [details]
and compare the results with different keyboard layouts, thanks.
Mozilla 1.7 on Windows 2000 Pro CZ SP4
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040616

Ctrl+Shift+L (open location)
---------------------------
English keyboard layout:
1) keydown charCode=0 keyCode=76 character=|| modifiers=Ctrl+Shift
2) keypress charCode=76 keyCode=0 character=|L| modifiers=Ctrl+Shift

Czech QWERTZ keyboard layout:
1) keydown charCode=0 keyCode=76 character=|| modifiers=Ctrl+Shift
2) keypress charCode=76 keyCode=0 character=|L| modifiers=Ctrl+Shift

Czech QWERTY keyboard layout:
1) keydown charCode=0 keyCode=76 character=|| modifiers=Ctrl+Shift
2) keyup charCode=0 keyCode=76 character=|| modifiers=Ctrl+Shift

Result: Works with English KL and Czech QWERTZ KL, DOES NOT work with Czech
QWERTY KL (see the "keypress" missing).


Ctrl+I (page info)
-----------------
English keyboard layout:
1) keydown charCode=0 keyCode=73 character=|| modifiers=Ctrl
2) keypress charCode=105 keyCode=0 character=|i| modifiers=Ctrl

Czech QWERTZ keyboard layout:
1) keydown charCode=0 keyCode=73 character=|| modifiers=Ctrl
2) keypress charCode=105 keyCode=0 character=|i| modifiers=Ctrl

Czech QWERTY keyboard layout:
1) keydown charCode=0 keyCode=73 character=|| modifiers=Ctrl
2) keypress charCode=105 keyCode=0 character=|i| modifiers=Ctrl

Result: Works as expected with all the keyboard layouts tested.
Product: MailNews → Core
Is problem gone?
Tomas reports "TB 2.0.0.0 doesn't have this bug".
QA Contact: localization
Product: Core → MailNews Core
So it may be the Ctrl+Shift combinations in that particular layout are not properly reported from core Gecko. BUt the bug was shifted back to Mailnews by "nobody" without explanation.

Is this bug still valid today?
Petr, do you have ability to check?
Flags: needinfo?(petr.v)
(In reply to Wayne Mery (:wsmwk) from comment #10)
> Petr, do you have ability to check?

The Ctrl+Shift+C shortcut is assigned to show the calendar on my system, to mark all messages read there is the Shift+C. 

I no longer have any XP system, but it works on Windows 7 US (Czech keyboard layout) and TB 52.7.0.
Flags: needinfo?(petr.v)
Thanks for testing. I think that is good enough for WFM
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.