Intermittent Unsent Messages Will Not Send

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: John Liebson, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040330 Firefox/0.8.0+
Build Identifier: Mozilla Thunderbird 0.5+ (20040331)

Place new outgoing messages in the Unsent Messages Folder; later, try to send them.

Right-click on Unsent Messages Folder, the Context Menu entry, "Send unsent
messages" is available. Try to send messages nothing whatsoever happens. That
nothing" includes the fact that there is no indication on the task bar of any
action being taken by Thunderbird. In short, when the problem arises, other than
the fact that the context menu indicates that unsent messages exist and should
be sent, there is a complete lack of further action.

Created a SMTP log file, tried to send the four unsent messages, nothing
happened, and there was nothing at all in the log file.

Reproducible: Sometimes
Steps to Reproduce:
1. See above.
2. Today, I edited the four unsent messages as new, and sent them from the
compose module.
3. I then erased the four entries in the unsent messages folder, created one new
message, placed it in the unsent folder, and was able to send it from there.

Actual Results:  
Sometimes the messages will be sent, other times nothing happens.

The problem started perhaps a week ago, with whatever daily release I happened
to be using, and persists, including with today's release as indicated bove.

Expected Results:  
Unsent messages should be sent, and always used to be.

I am not attaching the log file--as stated above, it was completely empty after
running it and trying to send the four unsent messages.

Was using GNOME-tb theme, but problem, when it arises, continues if I switch
Thunderbird to the default theme.
(Reporter)

Comment 1

15 years ago
Futher testing seems to indicate this behavior: If Thunderbird is shut down and
then restarted, it will not send any existing unsent messages, nor will it send
any new ones created after that restart.

However, if the Thunderbird user creates and sends a new message directly from
the Compose module after restarting the program, then Unsent messages will work.

It is as though something has to inform Thunderbird of its sending capabilities
before it will send any unsent messages.
(Reporter)

Comment 2

14 years ago
Yesterday, I created a new profile for further testing, and installed version
0.6a (20040420), installer version, Windows XP Home.

Several times during the day, I tested Unsent Messages, and it worked, including
before and after turning off/restarting Tbird.

Last night, I created and stored an unsent message. Computer goes into Standby
after two hours of being idle.

Computer wakes up automatically at 0400 to backup files such as Thunderbird.

This morning, around 0500, I restarted Tbird, and got my waiting email. However,
Tbird once again refused to send the waiting Unsent message. Once again, when
the cursor was on that folder, the option to send such messages was not
greyed-out, but did nothing.
(Reporter)

Comment 3

14 years ago
Another of my occasional comments on this problem, this time using version 0.6b
(20040429).

1. Last night, my wife created and saved as unsent one new message, using her
mailbox. This morning, after starting Thunderbird, I was unable to send this
message, except by recreating it as a new one and sending it from the compose
module.

2. I then created and save as unsent a message to myself, using my mailbox,
which is on the same SMTP account as that of my wife; result was the same as (1).

3. Perhaps two hours later, without having restarted Thunderbird, I tried again
as in (2), and this message was sent immediately. (In fact, while I was typing
this comment, Thunderbird retrieved the message I had sent a few minutes ago.

Frustrating, given the unpredictability of the problem, and the lack of any
ideas as to how to track down what is causing it.
(Reporter)

Comment 4

14 years ago
Further input to try to help you find the problem:

1. Two nights ago, my wife started Thunderbird, wrote three messages which she
stored as unsent. She forgot to shut down Tbird, which we usually do at the end
of the day so that my automated daily backup will backup all files.

The next morning, I logged on-line, clicked on the "Send/Get" button; my wife's
three unsent messages were sent, new email was received.

2. Last night, she started Tbird again, wrote two new messages which she stored
as unsent, and closed Tbird. This morning, when I started Tbird, I could only
send those messages by editing them as new ones; once again, even though placing
the cursor on the Unsent messages folder showed that Tbird was cognizant of
there being pending messages, because the context menu item was NOT greyed out,
nothing worked.

3. Several hours later, having received numerous email messages, and having sent
ONE message directly from the composition module, I wrote and stored another
message as unsent. When that was done, I logged on line, clicked on the
"Send/Get button again, and my unsent message was sent, as well as new incoming
messages being received.

This episode seems to confirm my suspicion (and it is ONLY that, I cannot prove
or disprove it) that the problem arises when Tbird has been shut down, and
perhaps it is related to the fact that my computer goes into "System standby"
after two hours of being idle. As outlined above, the night that Tbird was left
running, unsent messages were sent anyway, even though the computer was in
system standby when I entered the room where the computer lives.
(Reporter)

Comment 5

14 years ago
Using version 0.6+ (20040602), branch, installer version, I have finally pinned
down the behavior pattern:

1. Write a message and store as unsent, close Thunderbird, reopen Thunderbird,
try to send unsent message, will not work.

2. Delete existing unsent message, create a new message and store as unsent; try
to send, will not work.

3. Delete any and all unsent messages, close Thunderbird, restart, create unsent
message. Thunderbird will now send that message, and will continue to do so so
long as Thunderbird is not shut down with at least one unsent message remaining
in the unsent messages folder.

In layman's (i.e., a non-programmer's) words: Something, somewhere, is being
changed when Thunderbird is shutdown while at least one unsent message is
pending, causing Thunderbird to stop sending such messages.

I hope this helps you, Scott. If there is something on my computer, such as one
of the Thunderbird files, that you would like me to look at and provide
information from it while testing my above conclusions, please let me know.
(Assignee)

Comment 6

14 years ago
moving in for investigation now that John has a reproduceable test case.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → Thunderbird0.7
(Assignee)

Updated

14 years ago
Target Milestone: Thunderbird0.7 → Thunderbird0.9
(Reporter)

Comment 7

14 years ago
Discovered something else about this: I had two unsent messages from yesterday.
Started Thunderbird this morning, opened each message as new, resaved as unsent.
Thunderbird would not deliver those new unsent copies of yesterday's messages; I
had to send them as new ones.

[That was with version 0.7+ (20040824), I believe: I just installed version 0.7+
(20040827), so am not positive as to which nightly I was using earlier today.]
(Assignee)

Comment 8

14 years ago
I'll go out on a limb and guess that you still see this John? 
(Reporter)

Comment 9

14 years ago
Reply to Scott's Comment #8: How very ironic, given that I just came inside from
cutting down part of a dead juniper tree, and Scott says he's out on a limb!

Yes, I do, Scott, sorry: The behavior continues as I'd previously reported, or,
a bit more accurately, it did with the TB release of a few days ago. I installed
0930 earlier today; just tested it with today's release, problem continues, alas.

Comment 10

14 years ago
John, Scott..

Maybe a heavily-instrumented build can be made for John (i mean not only have
him turn on regular logging, but maybe add other printfs that specifically
interest you)? If he can reliably reproduce the problem, perhaps (if he does not
mind, of course) he can run your build, then send you copious amounts of output?
The problem does seem rather serious, even if it is not all that common.
Scott, I can take a look at this if you're not already working on it yet.
(Assignee)

Comment 12

14 years ago
go for it Vlad.

Thanks.
(Assignee)

Comment 13

14 years ago
(In reply to comment #11)
> Scott, I can take a look at this if you're not already working on it yet.

Vlad, do you think you'll have time to take a stab at this in the next week or
two? If not I may just end up pushing this off the .9 list for right now. 

(Assignee)

Comment 14

14 years ago
moving off the list. will take a fix if Vlad has a chance to take a look at this. 
Target Milestone: Thunderbird0.9 → Thunderbird1.0
(Assignee)

Comment 15

14 years ago
pushing off unless Vlad has some time. 
Target Milestone: Thunderbird1.0 → Thunderbird1.1
(Reporter)

Comment 16

14 years ago
Now, using version 1.0RC1 (20041201), this seems to have stopped completely:

1. Yesterday, with five messages ready to send, TB sent the first one, then got
new mail, and refused to send the four other messages.

2. Earlier today, TB refused to send two pending messages.

3. A minute ago, I wrote a new message, saved it as an Unsent Message; when I
logged on, TB refused to send this new message. As with those mentioned above, I
had to edit it as a new message and send it from the compose module.

N.B.: I have not tried the usual new profile for testing, etc. I'm only
reporting my continued dismay....

Comment 17

13 years ago
John, is this still happening to you? Have you tried a 1.1a build? (I don't know
of any fixes in this area, however, since 1.0 came out). If you could recreate
this with some sample messges, and send me a copy of the Unsent Messages and
Unsent Messages.msf file, perhaps I could see if there's something wrong with
one of them...
(Reporter)

Comment 18

13 years ago
(In reply to comment #17)
> John, is this still happening to you? Have you tried a 1.1a build? (I don't know
> of any fixes in this area, however, since 1.0 came out). If you could recreate
> this with some sample messges, and send me a copy of the Unsent Messages and
> Unsent Messages.msf file, perhaps I could see if there's something wrong with
> one of them...

Thanks for asking. Yes, it happens with version 1.0.2 (20050317), and I know
when it happens:

1. Create an unsent message.
2. Close Thunderbird.
3. Reopen TB and try to send the unsent message: It will not be sent.

This is repeatable every time TB is closed with unsent messages stored and ready
to be sent. 1.0.2 is the latest version I've tried; this bug continues to be
listed in the MozillaZine TB Build forum report on the latest builds; currently
showng there as "#239264 Intermittent Unsent Messages Will Not Send [Win]
(targeted for 1.1)" in thread
http://forums.mozillazine.org/viewtopic.php?t=280613 for example.

Comment 19

13 years ago
Those steps work fine for me, and afaik, no one else here can reproduce the
problem. So there must be something different about your setup. Seeing your
prefs.js file might be helpful as well...
(Reporter)

Comment 20

13 years ago
Created attachment 186624 [details]
Unsent message and prefs.js files

Here are the files requested by bienvenu. 

A bit of history: The problem arose months ago, as shown by my first Bugzilla
posting; the feature used to work.

One real oddity--but which arose after the bug in question--is that now unsent
messages are stored in my wife's account, pop.cybermesa-1.com, despite what is
called for by prefs.js.
(Assignee)

Comment 21

13 years ago
Sorry John, we tried again and still can't reproduce this tricky bug :(
Target Milestone: Thunderbird1.1 → ---
(Reporter)

Comment 22

13 years ago
Scott: I understand and appreciate your continued attempts.

I'm not (happily...) a programmer, so I have no idea what caused it to start
after a number of months of its working correctly, which makes it all the more
puzzling to me. That it has continued to not work properly even after creating a
few new TB profiles just adds to the mysterium magnum
(Reporter)

Comment 23

13 years ago
I found the culprit. I just created a new profile, wrote a few messages to be
sent later, each time closing TB, then restarting TB and successfully sending
them. I changed things each time, such as adding a second email account, then a
second identity to the first account. 

I then copied the following line from user.js in my currently-used TB profile
into a new user.js for the brand-new profile:

//Change location of Unsent Messages
user_pref("mail.default_sendlater_uri","mailbox://pop.cybermesa.com/Unsent%20Messages");

I then wrote another message to be sent later. It took a few tries to get TB to
reopen, as it had not yet created the new "send later" folder.

When TB did restart, it had created a new "unsent folder," but--as I've reported
previously, it did so for the second account, "pop1.cybermesa.com" instead of
pop.cybermesa.com. Furthermore, TB would not send the waiting unsent message.

There is apparently something wrong with the syntax of that line in user.js.
Obviously, I have no idea what the error is; perhaps you can figure it out.
(Reporter)

Comment 24

13 years ago
Problem solved!

I did a search of "unsent and messages" on MozillaZine, which turned up this
thread:http://forums.mozillazine.org/viewtopic.php?t=295494

In that thread, I noted that the name of the moved `unsent messages' is shown
not as I posted yesterday, but this way:

//Change location of Unsent Messages
user_pref("mail.default_sendlater_uri","mailbox://jliebson@pop.cybermesa.com/Unsent%20Messages");

Note the simple addition of "jliebson@"!

I do not know, and never will know, if I copied the line improperly many months
ago in creating a new profile, or if something in Thunderbird changed that
required the "jliebson@", or if it was all due to something quite different.
None of that matters any llonger, as unsent messages are now stored where I want
them and they are sendable after closing and restarting Thunderbird.

Thanks again to those who have tried to figure this one out. 
since the problem is solved without a checkin, please mark it wontfix or worksforme.
(Reporter)

Updated

13 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.