Loading above URL nearly blocks Mozilla for 10+ seconds

RESOLVED DUPLICATE of bug 148338

Status

()

Core
Layout: Tables
RESOLVED DUPLICATE of bug 148338
14 years ago
14 years ago

People

(Reporter: Samuel Rutishauser, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316

See summary

Reproducible: Always
Steps to Reproduce:
1. Load URL
2. Try to scroll around, change to another Tab ..
3. 

Actual Results:  
Experienced lag

Comment 1

14 years ago
Yes, I see that too. We're pretty slow on this page.

IE 6         : 3.5 seconds
Moz(20040401): 15-30 seconds (varies)

both loaded from disk. When I pause the rendering my callstack mostly looks like
this so my initial guess is Layout tables.

nsCellMap::GetDataAt(nsTableCellMap & {...}, int 168, int 411, int 1) line 2270
nsCellMap::RowIsSpannedInto(nsTableCellMap & {...}, int 168) line 2380 + 22 bytes
nsTableCellMap::RowIsSpannedInto(int 168) line 762 + 16 bytes
nsTableFrame::RowIsSpannedInto(int 168) line 7335 + 12 bytes
nsTableRowGroupFrame::CalculateRowHeights(nsIPresContext * 0x021930d8,
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, nsTableRowFrame *
0x00000000) line 674 + 15 bytes
nsTableRowGroupFrame::Reflow(nsTableRowGroupFrame * const 0x03bd19fc,
nsIPresContext * 0x021930d8, nsHTMLReflowMetrics & {...}, const
nsHTMLReflowState & {...}, unsigned int & 0) line 1311
nsContainerFrame::ReflowChild(nsIFrame * 0x03bd19fc, nsIPresContext *
0x021930d8, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0,
int 0, unsigned int 0, unsigned int & 0) line 935 + 31 bytes
nsTableFrame::ReflowChildren(nsTableFrame * const 0x03bd1934, nsIPresContext *
0x021930d8, nsTableReflowState & {...}, int 1, int 0, unsigned int & 0, nsIFrame
* & 0x00000000, nsRect & {...}, int * 0x00000000) line 3238 + 50 bytes
nsTableFrame::ReflowTable(nsIPresContext * 0x021930d8, nsHTMLReflowMetrics &
{...}, const nsHTMLReflowState & {...}, int 1073741824, nsReflowReason
eReflowReason_Resize, nsIFrame * & 0x00000000, int & 0, int & 1, unsigned int &
0) line 2156
nsTableFrame::Reflow(nsTableFrame * const 0x03bd1934, nsIPresContext *
0x021930d8, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...},
unsigned int & 0) line 1998
nsContainerFrame::ReflowChild(nsIFrame * 0x03bd1934, nsIPresContext *
0x021930d8, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0,
int 0, unsigned int 3, unsigned int & 0) line 935 + 31 bytes
nsTableOuterFrame::OuterReflowChild(nsTableOuterFrame * const 0x03bd1834,
nsIPresContext * 0x021930d8, nsIFrame * 0x03bd1934, const nsHTMLReflowState &
{...}, nsHTMLReflowMetrics & {...}, int 9795, nsSize & {...}, nsMargin & {...},
nsMargin & {...}, nsMargin & {...}, nsReflowReason eReflowReason_Incremental,
unsigned int & 0, int * 0x00126d20) line 1325 + 47 bytes
nsTableOuterFrame::IR_InnerTableReflow(nsTableOuterFrame * const 0x03bd1834,
nsIPresContext * 0x021930d8, nsHTMLReflowMetrics & {...}, const
nsHTMLReflowState & {...}, unsigned int & 0) line 1685 + 78 bytes
nsTableOuterFrame::IR_TargetIsInnerTableFrame(nsTableOuterFrame * const
0x03bd1834, nsIPresContext * 0x021930d8, nsHTMLReflowMetrics & {...}, const
nsHTMLReflowState & {...}, unsigned int & 0) line 1438 + 31 bytes
nsTableOuterFrame::IR_TargetIsChild(nsTableOuterFrame * const 0x03bd1834,
nsIPresContext * 0x021930d8, nsHTMLReflowMetrics & {...}, const
nsHTMLReflowState & {...}, unsigned int & 0, nsIFrame * 0x03bd1934) line 1411 +
31 bytes
nsTableOuterFrame::IncrementalReflow(nsTableOuterFrame * const 0x03bd1834,
nsIPresContext * 0x021930d8, nsHTMLReflowMetrics & {...}, const
nsHTMLReflowState & {...}, unsigned int & 0) line 1391 + 42 bytes
nsTableOuterFrame::Reflow(nsTableOuterFrame * const 0x03bd1834, nsIPresContext *
0x021930d8, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...},
unsigned int & 0) line 1948 + 31 bytes
nsBlockReflowContext::ReflowBlock(const nsRect & {...}, int 1,
nsCollapsingMargin & {...}, int 1, nsMargin & {...}, nsHTMLReflowState & {...},
unsigned int & 0) line 546 + 42 bytes
nsBlockFrame::ReflowBlockFrame(nsBlockReflowState & {...}, nsLineList_iterator
{...}, int * 0x001277a8) line 3034 + 56 bytes
...
...
...
Severity: minor → normal
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout: Tables
Ever confirmed: true
when changing components, please also reassign to the default owner...
Assignee: general → nobody
QA Contact: general → core.layout.tables

Comment 3

14 years ago
How does this bug differs from bug 148338, bug 160816, bug 198827, bug 220997,
bug 226243 and bug 233311 	

Comment 4

14 years ago
It's not.

*** This bug has been marked as a duplicate of 148338 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.