1.7b: Error msg when replying to newsgroup posting through news and mail

RESOLVED INCOMPLETE

Status

--
critical
RESOLVED INCOMPLETE
15 years ago
10 years ago

People

(Reporter: t.rother, Unassigned)

Tracking

Trunk
x86
Linux
Bug Flags:
blocking1.7 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.7b) Gecko/20040316
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.7b) Gecko/20040316

I receice news on a standard leafnode newsserver (version 1.9.46.rel). When
posting, I get an error message which makes no sense.

Reproducible: Always
Steps to Reproduce:
1. receice news on a server without authentication or SSL
2. reply to a posting by using "reply to all"
3. Message should be sent to the newsgroup and through private mail
4. Instead of that, I get the error message "news error" (see attachment) whcih
refers to the IMAP mail server, but not to the news machine!
Actual Results:  
Message to the news group is not sent.

Expected Results:  
No error message, message sent.

The error msg shows the connection string of the MAIL server (imap) which really
makes no sense when we have something wrong inside news. This behaviour is new
since 1.7b. I used the same setting with 1.6 without problems.
(Reporter)

Comment 1

15 years ago
Created attachment 145676 [details]
1.7b error message when posting a reply through news and mail
wfm current cvs trunk build on win2k with news server:
280 nnrpd-indi compile time: Apr  5 2004, 17:50:08
Summary: 1.7b: Error msg when replying to newsgroup posting through news and mail → 1.7b: Error msg when replying to newsgroup posting through news and mail

Comment 3

15 years ago
Maybe this has to do with the fix for bug 228597. Thommie, when saving your
reply as draft and looking at the source, it should have X-Identity-Key and
X-Account-Key there.
Please look up you prefs.js (or about:config) if the account from the latter
line really refers to the NNTP server.

Does this error also occurs when only replying, not Reply All?
(Reporter)

Comment 4

15 years ago
Christian,
It appears as I don't have either X-Identity-Key or
X-Account-Key setings in my prefs.js. The user profile was freshly created with
a 1.6 final build (ok ok, I know this is not "best practice" ;-) ). Are these
keys something which was introduced during 1.7 cycle? Does it make sense if I
add these settings manually or is it better if I create the whole new profile
with a 1.7 build?

(P.S. Verified this bug for the 20040408 Win-nightly build)

Comment 5

15 years ago
Er, sorry if my description was unclear. It's ok there's no pref "X-Account-Key".
I meant you should look for a pref that contains the key from the X-Account-Key
line as value. E.g. 
  user_pref("mail.account.account13.server", "server16");
if the mail contains "account13".
And then go to the type pref for this server. E.g.
  user_pref("mail.server.server16.type", "nntp");
(Reporter)

Comment 6

15 years ago
Yep, the nntp entry is "server3"

mail.account.account3.server server3
mail.server.server3.type  nntp

Info: I am using three imap mail account entries (just to change the sender
adress, in fact only the first imap account is used for incoming mail) and one
nntp entry to connect to my nntp server (inside the lan).
(Reporter)

Comment 7

15 years ago
Re-confirmed for the latest nightly (Mozilla 1.7b
Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.7b) Gecko/20040414) and
with a profile which was created with the same build. The news messages are not
sent, therefore I raised the severity of this bug to "critial". I would also
vote for this as being a "1.7 blocker", but I am not shure if I am allowed to
change the "blocking" flags ...
Severity: major → critical
(Reporter)

Comment 8

15 years ago
Confirmed a second time for the latest 1.7.RC1 (Mozilla 1.7b
Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.7b) Gecko/20040421). This needs to
be solved before the final release!
Flags: blocking1.7+
(Reporter)

Comment 9

15 years ago
Note that I have the following setup for the nntp server: All written messages
are not copied to the Local Folders/Sent but to an IMAP Folder ("Sent_News") on
the first mail account - maybe this is the reason for the bug. This setting
worked in all releases before 1.7b, it looks like a regression ...

Comment 10

15 years ago
Thommie, only drivers are allowed to set the blocking flags!
Flags: blocking1.7+ → blocking1.7?

Comment 11

15 years ago
Yes, maybe this pref can be the reason. Why don't you just temporarily set the
sent folder to Local Folders/Sent and try with it?

On the other side it would be strange since the message is copied *after*
sending it, so the message should nevertheless show up on the newsserver.
Is the sent folder for mails also on IMAP?
(Reporter)

Comment 12

15 years ago
Christian, sorry for the blocking flag, I was not shure about that (see comment
7). I tested this again but I see no real systematics yet: the error sometimes
shows up and sometimes not. I still have to look for some reproducible reason
for that. And, yes, all "sent" folders for all mail/news accounts are on the
same IMAP account (but in different IMAP folders like sent_news, sent_private,
sent_business).
(Reporter)

Comment 13

15 years ago
Christian, this problem is still present and reproducible for 1.7RC1. I think it
really needs to be solved bevore the final build, but what can we do? Do you
need more info?

Comment 14

15 years ago
My current question is still the one from my comment #11.
Additionally, does the problem also occur if you only reply to a newsgroup?
(Reporter)

Comment 15

15 years ago
The error disappears when I use a local folder to store the message copy. And it
shows up explicitely when using a "mixed" header with both e-mail and newsgroup
recipients.
(Reporter)

Comment 16

15 years ago
OK, the error appeared again ;-( The Setting: rv:1.7b de_DE, Gecko/20040421;
Newsserver message copy folder is now set to "Local Folder" (!). The message
whch caused the error (see attchment 1) contained a newsgroup plus a mail
address as the recipients.

I will now switch to RC2 to do further testing, but I still believe this is a
blocker for the final release.
I don't think we're going to block on this but there's still some time to get a
fix. I've asked Seth to take a look at this and if he things it should block and
has some plan to get it fixed, we'll consider a patch for inclusion.
Flags: blocking1.7? → blocking1.7-
(Reporter)

Comment 18

15 years ago
OK, I'm open for further testing. Does it make sense if I add parts of my
prefs.js here?
accepting, but I'm not sure how to reproduce this.

thommie, are you doing "send later" or "save as draft" before posting the message?
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Reporter)

Comment 20

15 years ago
Seth, no, I'm sending immediately. I now use the RC2 and I had no problems for
two days. But I think it's better if we investigate this further, just to be
shure. Just let me know what you need.
(Reporter)

Comment 21

15 years ago
One hour later, the error appeared again in RC2 (Gecko/20040514). Same message
as seen in attachment 1 [details] [diff] [review].
(Reporter)

Comment 22

15 years ago
Different behaviour in 1.7.b RC2 compared to RC1: The error message still
appears, the news message is not sent, but the message copy is posted into the
IMAP folder.
(Reporter)

Comment 23

15 years ago
The IMAP error message is still present in RC3 (Mozilla/5.0 (X11; U; Linux i686;
de-AT; rv:1.7) Gecko/20040608)
(Reporter)

Comment 24

15 years ago
The IMAP error message is still present in 1.7 final(Gecko/20040616). Sometimes
it also appears when replying to a newsgroup only (!). When replying through
news AND mail, the news part is not posted after the error message. This makes
the application unusable for me.
(Reporter)

Comment 25

15 years ago
Error message is also present in a freshly created Thunderbird profile (version
0.7 20040616)
(Reporter)

Comment 26

15 years ago
Hi Seth,
just want to send a reminder, that this problem is still present in both 1.7 
final (Linux and Win) and Thunderbird 0.7, no matter what kind of news server or
imap server is used (I switched from uw-imap to cyrus-imap recently). The
thunderbird error message is a bit different ("tls_init()"), but it still
prevents me from forwarding mail to news and from replying into a newsgroup plus
sending a mail reply ("reply to all") with the same message. And it is still
"unpredictable": sometimes the news reply is sent, sometimes not. It appears to
be a news problem as it also happens when the message copy is put into a local
folder, instead of an IMAP folder.

I am still willing to help, but I need a reply from developers. And I don't want
to spend time on newer builds (1.8x) until I definitely know that someone is
working on this.
(Reporter)

Comment 27

15 years ago
New error message in 1.7 final: "tls_init[] failed". This occured on a reply to
normal (leafnode) server on the same host (localhost) without any SSL settings.
See attachment. Second attachment shows the mail which could not be sent due to
this error message.
(Reporter)

Comment 28

15 years ago
Created attachment 153663 [details]
Error message when posting a news reply
(Reporter)

Comment 29

15 years ago
Created attachment 153664 [details]
The message which triggered the "tls_init() failed" window
(Reporter)

Comment 30

15 years ago
Enclosed is another strange error which occured now: Mozilla tries to sent a
message to IMAP, although the reply was directed to a newsgroup, by selecting
the header line "newsgroup: [name]". That really makes no sense...
(Reporter)

Comment 31

15 years ago
Created attachment 153766 [details]
Strange error message when sending a news reply

Comment 32

15 years ago
David, since Thommie apparently receives IMAP strings, maybe you know what goes on.

Comment 33

15 years ago
Thommie, could you send me your entire prefs.js? Also, when you tried this with
a new tbird profile, did you set up all your accounts again, or copy the
prefs.js from an old profile?

I have a feeling that something odd might be going on on the server side since
it looks like you're getting your news from a cyrus imap server, if that last
error message is to be believed.
(Reporter)

Comment 34

15 years ago
David, no, the server side ist OK here. It seems like Mozilla is puzzled somehow
or something is really wrong in the prefs.js. Mozilla tries to send news to an
IMAP server which is really really strange ... But this happens only sometimes,
not always, that makes it hard to analyse.

I'll attach the prefs.js in a private mail 
(Reporter)

Comment 35

14 years ago
Hey, this bug is 2 months old, I just want to confirm that the same problems are
present even in Thunderbird 0.8. And unfortunately, I got no response from David
upon my prefs.js ;-(. David, has anything been done here? Does it make sense if
I test a 1.8a nightly now?
I still feel this is a major thing which needs at least to be investigated in
detail before 1.8b.

Comment 36

14 years ago
I sent several responses - did you not get them? I couldn't find anything
special in your prefs.js, and my only suggestion was that you make sure you're
using the latest version of enigmail, because you weren't using the version of
enigmail that's supposed to work with 1.7 or tbird .8, according to enigmail and
your prefs.js
(Reporter)

Comment 37

14 years ago
> I sent several responses - did you not get them? 
Hm, no, sorry. Maybe it was lost in my spam filter, but I can't believe that.
Nevertheless: I am still running the moz 1.7 final (20040608) with enigmail
0.84.1.0, which should be the correct version (I have no problems with it). On
thunderbird, its the combination tb 0.8 and enigmail 0.86.1.0

The strange messages from the IMAP server (see attachments) still appar only
when replying to a message by personal mail (-> e-mail adress) AND into the
newsgroup (-> newsgroup name) where the message appeared. It still shows up only
sometimes, not always (that makes it so hard to reproduce, I know). And still,
the mail response copy is always sent while the news response copy fails.

I would guess that something is wrong in the way the mozilla mail is reading
message headers and how it decides to put which message to which server (imap or
nntp). Maybe its trying to sent the "news response copy" also to the mail
server? I can't imagine any other reason why a message, which should be sent to
the news server, triggers a response from an imap server...

Bye, Thomas

Comment 38

14 years ago
mail to Thomas seems to be bouncing so I'll just put it in the bug...

Thomas,
   Did I get you to generate an IMAP, SMTP, and NNTP log of this bug happening?

If not, follow these instructions,

http://www.mozilla.org/quality/mailnews.html#pop

except, we want logs of all three protocols at the same time, so

setenv NSPR_LOG_MODULES=IMAP:5,SMTP:5,NNTP:5

thx,

- David 
(Reporter)

Comment 39

14 years ago
Enclosed is a log for Mozilla 1.7.3 Mozilla/5.0 (Windows; U; Windows NT 5.0;
de-AT; rv:1.7.3) Gecko/20040910. I used setenv
NSPR_LOG_MODULES=IMAP:5,SMTP:5,NNTP:5. What I did:

- reading a news message 
- replying to both the newsgroup and the sender ("Reply to all")
- Editing the reply message
- "Send". Then the Mozilla hangs, I can not close the edit window.

After that, I closed Mozilla (File, Exit). The edit window remained, I had to
close it separately.

This is the de_DE version, but I had this also in the en_EN original. In the 1.8
nightlies I used it did not occur yet. But that's only a matter of time, I believe.

Did you get my mail message? (5.10, Msg-ID 4162494D.6040601@netzwissen.de)
(Reporter)

Comment 40

14 years ago
Created attachment 161351 [details]
Log created while replying to all (-> newsgroup and mail)

Comment 41

14 years ago
Thommie, I don't see anything in the protocol log from SMTP, so it rather sounds
to me like enigmail is hanging processing the message before we even start to do
smtp...again, sounds like a configuration issue with enigmail.

I did get <4162494D.6040601@netzwissen.de> - that's when I requested the
protocol log in the bug because mail directly to you bounced.
(Reporter)

Comment 42

14 years ago
David: "configuration issue with enigmail", what does that mean? Do we need to
move the bugfixing job to the enigmail people (Patrick Brunschwig)? Or do you
mean there's a configuration error on my side? In this test I used the 1.73
mozilla with the appropriate enigmail version (enigmail 0.86.1 and enigmime 0.86.0).

Note that in this log I did not get one of the strange messages shown in
attachments 1,2,4. Not yet - but I'll try hard ;-)

Concerning "mail directly to you bounced.": Can you send the bouncing info (if
you have some) to my backup adress at thommie.rother@t-online.de? Thanks!

Comment 43

14 years ago
re enigmail, by configuration issue, I meant a mismatch between the mozilla and
enigmail/enigmime versions - if a mozilla interface changes, you need to have
the version of enigmail that works with that changed interface, or else things
will crash/hang/behave bizarrely. However, it sounds like you've checked that
you have the right versions. If you temporarily uninstall enigmail, does the
problem go away? If so, it sounds like getting the enigmail folks involved might
be helpful, at least to figure out what's going on. I don't know enough about
enigmail to say anything more... 
(Reporter)

Comment 44

14 years ago
David,
we now have reports that this problem appears even with a CLEAN
Mozilla/Thunderbird which has NO enigmail extensions. And, that it appeared
first with the post-1.6 code. This supports my position that it is something
which came up from/around the new "multiple identity support".

Forwarding replies to a "mixed audience" (reply to mailadress and newsgroup
which leads to a message to the mail AND the news account) seem to trigger this
frequently, but, unfortunately, not always.

What shall we do next?
Product: MailNews → Core
(Reporter)

Comment 45

14 years ago
Re-tested this with 1.8a6: Mozilla now has a new fuction which PREVENTS me from
forwarding a received mail into a newsgroup. This is definitely a MAJOR
disadvantage/regression, which would make Mozilla/Thunderbird USELESS for a
large number of our users here! As this is more a "useability issue", I filed a
news bug for this.
(Reporter)

Comment 46

14 years ago
Side note: the bug-ID mentioned in comment #45 is
https://bugzilla.mozilla.org/show_bug.cgi?id=278198 

(I don't want to use the bug dependencies here...)
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
Status: ASSIGNED → NEW
Filter on "Nobody_NScomTLD_20080620"
QA Contact: stephend → networking.news
Thommie, does this still happen with TB 2.0.0.* or TB 3.0a*? If no response in three weeks, I will close this bug as RESO INCO.
Whiteboard: [jcranmer:unconfirmed] closeme 2008-07-17
RESO INCO per last comment. If you feel this change was made in error, please respond with your comments why.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [jcranmer:unconfirmed] closeme 2008-07-17
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.