Unable to confirm other people's bugs, even with the canconfirm permission

RESOLVED FIXED in Bugzilla 2.18

Status

()

Bugzilla
User Accounts
RESOLVED FIXED
14 years ago
6 years ago

People

(Reporter: Petey, Assigned: gerv)

Tracking

unspecified
Bugzilla 2.18
Bug Flags:
approval +
approval2.18 +
blocking2.18 +

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
I have the canconfirm permission, but I can't confirm.  I am only having
problems confirming bugs from other users; I /am/ able to register my own bugs
as 'New'.

Comment 1

14 years ago
Yes I have the same problem.
Is this on mozilla.org?  How long ago did this start happening?

Comment 3

14 years ago
Yes this is on bugzilla.mozilla.org. At first I guessed it must be because I was
given confirm on the mozilla browser and that I was now trying to confirm bugs
on Camino and Firefox, but I can see no mention of privs being restricted to
products.

Comment 4

14 years ago
Same thing happened to me on bug 224166.
I can select "Confirm bug (change status to NEW)", add a comment, and add to CC
list. In the bug processed screen, my comment is added, my address is added to
the CC list, but the status stays at UNCONFIRMED.

Comment 5

14 years ago
Chris, I tried confirming to new on Bug 224166 but had the same problem. This is
very annoying.
Dave: several people are seeing this. It's somewhat scary, and would be good to
nail down for 2.18. What can we do to diagnose it, do you think? Get one of
these users to lend us their account?

Gerv
Flags: blocking2.18?
(Reporter)

Comment 7

14 years ago
I volunteer my account, if you can use it.
Yeah, probably good to nail it, if we can.  No idea how to trace it...  we
should be able to clone an account instead of stealing one...
Flags: blocking2.18? → blocking2.18+
Target Milestone: --- → Bugzilla 2.18
Created attachment 153278 [details] [diff] [review]
Patch v.1

Seems like canconfirm just plain didn't work :-( 

The code does a CheckCanChangeField() call for a fake field called
"canconfirm". CheckCanChangeField() wasn't allowing people in the canconfirm
group to change any field apart from specific values of bug_status, and so the
request was failing, and "everconfirmed = 1" was not being added to the SQL. So
the bug stayed UNCONFIRMED.

You could still confirm your own bugs because the reporter can change anything.
But no-one with canconfirm can confirm other people's bugs at the moment. This
has obviously been true since the last b.m.o. update, and as far as I can see,
since February 2003, when I "fixed" bug 186994.
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&root=/cvsroot&subdir=mozilla/webtools/bugzilla&command=DIFF_FRAMESET&file=process_bug.cgi&rev2=1.178&rev1=1.177


Shows how little it's actually used without editbugs...

Gerv
Assignee: myk → gerv
Status: NEW → ASSIGNED
Attachment #153278 - Flags: review?(justdave)

Comment 10

14 years ago
Comment on attachment 153278 [details] [diff] [review]
Patch v.1

r=joel
By inspection, not tested. But the logic makes total sense
Attachment #153278 - Flags: review+
Flags: approval2.18?
Flags: approval2.18?
Flags: approval2.18+
Flags: approval+
OS: Windows XP → All
Hardware: PC → All
Fixed on both trunk and branch.

Checking in process_bug.cgi;
/cvsroot/mozilla/webtools/bugzilla/process_bug.cgi,v  <--  process_bug.cgi
new revision: 1.206; previous revision: 1.205
done

Checking in process_bug.cgi;
/cvsroot/mozilla/webtools/bugzilla/process_bug.cgi,v  <--  process_bug.cgi
new revision: 1.205.2.1; previous revision: 1.205
done

Gerv
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 12

14 years ago
I don't mean to moan, but when will this actually take effect on this site?
When we next update. I don't know if we have an ETA for this at the moment; the
last ETA was "after Firefox 1.0".

Gerv
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.