"Clear Log" does not refresh pane with log

RESOLVED WONTFIX

Status

MailNews Core
Filters
--
minor
RESOLVED WONTFIX
14 years ago
10 years ago

People

(Reporter: Norbert Pabis, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

1.7 Branch
x86
All

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007

In "Filter Log" dialog pressing "Clear Log" clears log, but does not refresh the
log view. The Log is still visible after clear, you have to reopen"Filter Log"
to see it cleared.

Reproducible: Always

Steps to Reproduce:
1. In "Filter Log" dialog press "Clear Log"
2.
3.

Actual Results:  
The log view is not cleared though the log itself is cleared.

Expected Results:  
Clear the log view.

Comment 1

14 years ago
IMHO this also seems to be a duplicate of bug 218774 which (according to the
logs there) seems to have fixed by the end of April 2004...

NB.: On Mozilla 1.7b (Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7b)
Gecko/20040416) it still existed...

Comment 2

14 years ago
I can confirm this on Mozilla 1.7 RC2 Windows XP. FWIW, it was a newsgroup filter.

Comment 3

14 years ago
The same bug exists for junk mail log
XPSP1 - Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040514

Comment 4

14 years ago
Changing to NEW.
I don't have power to change the OS, but it should be changed to ALL.

Comment 5

14 years ago
Reporter: Do you still see this bug with a current Mozilla build (note: the fix
wasnt in 1.7 branch, so test with 1.8a1 or newer)?
(Reporter)

Comment 6

14 years ago
Yes. In 1.7 on Linux the bug is still present for "Clear log" in "Message
filters" and "Junk mail controls".

Comment 7

14 years ago
Consider this bug CONFIRMED. I just haven't been able to mark it as CONFIRMED
because of bug 240093 .

Comment 8

14 years ago
(In reply to comment #6)
> Yes. In 1.7 on Linux the bug is still present for "Clear log" in "Message
> filters" and "Junk mail controls".

I asked you to test with 1.8a1 (or 1.8a2 now) and not with Mozilla 1.7.

Comment 9

14 years ago
Confirming and changing OS=All as per previous comments

As it was fixed on the trunk with bug 218774, I mark this one for the 1.7
branch, where it definitely still exists. The patch of attachment 146423 [details] [diff] [review] should
fix this here, too. But I could not test that yet.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Version: Trunk → 1.7 Branch

Comment 10

13 years ago
Created attachment 160821 [details] [diff] [review]
The same patch as in trunk

Tested, this does it for 1.7.x, too.

Updated

13 years ago
Attachment #160821 - Flags: superreview?(sspitzer)
Attachment #160821 - Flags: review?(mscott)
Attachment #160821 - Flags: approval1.7.x?

Updated

13 years ago
Attachment #160821 - Flags: superreview?(sspitzer) → superreview+

Updated

13 years ago
Attachment #160821 - Flags: review?(mscott) → review+
Product: MailNews → Core

Comment 11

13 years ago
Comment on attachment 160821 [details] [diff] [review]
The same patch as in trunk

a=asa for 1.7.x checkin.
Attachment #160821 - Flags: approval1.7.x? → approval1.7.x+

Comment 12

13 years ago
Can some check this in, please? Would be nice if it was in for 1.7.6...

Comment 13

13 years ago
Scott, can you please get this small, approved patch into the 1.7 branch?

Comment 14

13 years ago
Could anyone please check this in to the branch? It was already approved for
1.7.6...

Comment 15

13 years ago
As far as I know, if you miss a (branch) release, you must rerequest approval...

Updated

13 years ago
Attachment #160821 - Flags: approval1.7.9?

Updated

13 years ago
Attachment #160821 - Flags: approval1.7.9? → approval1.7.11?

Updated

13 years ago
Attachment #160821 - Flags: approval1.7.11? → approval1.7.11-

Updated

13 years ago
Attachment #160821 - Flags: approval1.7.12?

Comment 16

12 years ago
Comment on attachment 160821 [details] [diff] [review]
The same patch as in trunk

Strange, why was timeless' request for 1.7.12 approval	changed to 1.7.13?
Well, I add a request for 1.7.12... If this still isn't granted I guess I can
just mark this WONTFIX.
Attachment #160821 - Flags: approval1.7.12?

Updated

12 years ago
Attachment #160821 - Flags: approval1.7.12?
Comment on attachment 160821 [details] [diff] [review]
The same patch as in trunk

out of scope for a security release.
Attachment #160821 - Flags: approval1.7.13? → approval1.7.13-

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX

Updated

12 years ago
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Updated

12 years ago
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WONTFIX
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.