<table height="100%"></table> takes up space (gap on sonique.lycos.com)

RESOLVED DUPLICATE of bug 241161

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 241161
14 years ago
14 years ago

People

(Reporter: Hussam Al-Tayeb, Unassigned)

Tracking

({regression, testcase})

Trunk
regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.7 -
blocking1.8a1 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040409 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040409 Firefox/0.8.0+

When I open http://sonique.lycos.com , there is a gap at the top of the page.
This bug did not exist in mozilla 1.6

Reproducible: Always
Steps to Reproduce:
1.Open http://sonique.lycos.com
2.Notice the big gap at the top of the page


Actual Results:  
there is a big gap at the top of the page.

Expected Results:  
there shouldn't be a big gap at the top of the page
(Reporter)

Updated

14 years ago
Keywords: regression
(Reporter)

Comment 1

14 years ago
See http://validator.w3.org/check?uri=http://sonique.lycos.com
it gives a fatal error 
Fatal Error: No DOCTYPE specified!
but somehow it used to render correctly in firefox0.8 (1.6)
(Reporter)

Updated

14 years ago
Summary: There is a big gap at the top of the page → There is a big gap at the top of the page sonique.lycos.com
(Reporter)

Comment 2

14 years ago
Can somebody confirm this ?
(Reporter)

Updated

14 years ago
Flags: blocking1.8a?
Flags: blocking1.7?

Comment 3

14 years ago
confirming firefox 20040409 trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

14 years ago
Where's the minimal testcase people? Without a minimal testcase a layout bug
can't be fixed (and shouldn't be set to NEW in most cases).
Flags: blocking1.8a?
Flags: blocking1.8a-
Flags: blocking1.7?
Flags: blocking1.7-
(Reporter)

Comment 5

14 years ago
Created attachment 145817 [details]
simplified testcase

simplified testcase attached
Hussam, thank you for the testcase.

Bernard, please read
http://groups.google.com/groups?dq=&hl=en&lr=&ie=UTF-8&oe=UTF-8&th=ac50fff3f060ead7

Bernd, didn't we recently make empty tables like that actually display, whereas
they used not to?  Should we just evangelize this site, or should we make not
displaying them a quirk?
Summary: There is a big gap at the top of the page sonique.lycos.com → <table height="100%"></table> takes up space (gap on sonique.lycos.com)
(Reporter)

Comment 7

14 years ago
Ok, I got some input about this from a couple of people.
what's happening here is that after opening the table, there are some script
elements. Firefox0.8 closes the table right after those script elements whereas
firefox0.8 (1.6 ) did not. Hence, the rest of the page is not being included in
the table because the table is now closed.
> Firefox0.8 closes the table right after those script elements whereas
> firefox0.8 (1.6 ) did not. 

Er... you're talking about the same browser version there?

Looks like this table-closing issue is what we need a testcase for?
(Reporter)

Comment 9

14 years ago
(In reply to comment #8)
sorry I meant 0.8+ (1.7 ) and firefox 0.8 (1.6)
Ah, ok.  Note that I doubt that our parsing changed here (which is what comment
7 claims to have happened; that's why I'd love to see a testcase showing that
comment to be correct).
(Reporter)

Comment 11

14 years ago
(In reply to comment #8)
After thinking about this, the table closing issue seems to be another bug, so I
think the testcase attached is valid.
If you view the testcase in firebird0.8 (1.6), the empty table won't shove the
the rest of the page down.
Right.  Per standards it SHOULD shove it all the way down.  The only question is
whether we want to violate standards in this case, and if so how.

Comment 13

14 years ago
This was also an issue on Mozilla 1.6!!
Blocks: 241161

Updated

14 years ago
Keywords: testcase

Comment 14

14 years ago
This bug also creates a large gap on http://www.girlpaladin.com/introverts.html.
 (I made a testcase and it was essentially the same as the one here.)
Blocks: 245658
Blocks: 245434

Comment 15

14 years ago
fixed by checkin for bug 241161

*** This bug has been marked as a duplicate of 241161 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
No longer blocks: 245434
You need to log in before you can comment on or make changes to this bug.