images displayed over the top of text, layout is incorrect.

VERIFIED DUPLICATE of bug 241161

Status

()

Core
Layout: Tables
VERIFIED DUPLICATE of bug 241161
14 years ago
14 years ago

People

(Reporter: Matthew W, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040421
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040421

In the page at http://www.iinet.net.au/products/home/bliink/bliink256lite.html
the adsl details are overlayed with a menu item.
The adsl plan details should be on the left hand side.
Works ok with IE6 and also Firefox version 0.8

Reproducible: Always
Steps to Reproduce:
1. goto URL http://www.iinet.net.au/products/home/bliink/bliink256lite.html
2.
3.

Actual Results:  
Layout incorrectly displayed

Expected Results:  
layout should be correctly displayed.

works ok with Firefox version 0.8

Comment 1

14 years ago
regressed Mozilla 1.7a BuildID 2003122409, 
working Mozilla 1.7a BuildId 2003122208, Mozilla 1.6, Mozilla 1.4.2

http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=SeaMonkeyAll&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2003-12-22+06%3A00&maxdate=2003-12-24+09%3A00&cvsroot=%2Fcvsroot

uneducated guess: Bug 227123  	empty tables can have a size
Keywords: regression

Comment 2

14 years ago
forgot to confirm

seems to me that the left border of two tables is rendered with the width of the
tables, and then the tables to the right of this thick border, so the tables
overlap the neighboring elements.
Assignee: jdunn → nobody
Status: UNCONFIRMED → NEW
Component: Layout: Images → Layout: Tables
Ever confirmed: true
QA Contact: core.layout.images → core.layout.tables
Please don't confirm layout bugs without simplified testcases.
The markup has:

  <table width="540" border="0" cellspacing="0" cellpadding="0" align="left"
   bordercolor="#ffffff" height="146">
  </table>
  <table width="540" border="0" cellspacing="0" cellpadding="0" height="145"
   bgcolor="white">

and then content.  So all the content is pushed to the right by 540 px.  That's
the right behavior, given that markup.
Depends on: 241161
Depends on: 240148
No longer depends on: 241161

Comment 5

14 years ago
re comment #4:
there is an empty table with width 540, followed by a table with content, width
540, so all the content is pushed to the right by 540 px.

Thanks for the clarification, so I can stop working on a testcase.
I confirmed this bug based on a 2 day regression time span, and a guess that 
 Bug 227123  	empty tables can have a size
changed the behaviour.



*** This bug has been marked as a duplicate of 241161 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 6

14 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a2) Gecko/20040608
Tinderbox build, Build ID: 2004060823

2004-06-08 21:13	bmlk%gmx.de 	mozilla/ layout/ html/ table/ src/
nsTableFrame.cpp 	3.571 	3/1  	empty tables should not have a size in quirks
mode. bug 241161 r/sr=bzbarsky
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.