If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Context menu text is right aligned in date area

RESOLVED FIXED in Thunderbird0.9

Status

Thunderbird
Mail Window Front End
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: Marc O'Morain, Assigned: Scott MacGregor)

Tracking

({helpwanted})

unspecified
Thunderbird0.9
x86
Windows 2000
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040310 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040310 Firefox/0.8.0+

When you right click on the date in the preview pane or in a message window the
text in the pop-up menu is right aligned.

Reproducible: Always
Steps to Reproduce:
1. Right click on the date.

Actual Results:  
The pop-up menu text is right aligned.

Expected Results:  
Pop-up menu text is left aligned.

Mozilla Thunderbird 0.5+ (20040407)
(Reporter)

Comment 1

14 years ago
Created attachment 146504 [details]
A screenshot of the bug happening.
(Assignee)

Updated

14 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → Thunderbird0.7
(Assignee)

Comment 2

14 years ago
that really is wild. I bet it's because the date field itself gets right
justified against the edge? Maybe a style is bleeding through into the context
menu. This will be a great help wanted bug for someone looking to get their feet
wet.
Keywords: helpwanted
(Assignee)

Updated

14 years ago
Target Milestone: Thunderbird0.7 → Thunderbird0.9

Comment 3

14 years ago
Created attachment 150734 [details] [diff] [review]
aligning date

Updated

14 years ago
Attachment #150734 - Flags: review?(mscott)
(Assignee)

Comment 4

13 years ago
I think a better approach to fixing this would be to put a selector on the
context menu popup to over ride the text alignment..

something like:

#collapseddateValue > popup > menuitem {
  text-align: left;
}

except that doesn't actually work. The syntax needs adjusted to something that
will work. 
(Assignee)

Comment 5

13 years ago
Created attachment 160413 [details] [diff] [review]
the fix
Attachment #150734 - Attachment is obsolete: true
(Assignee)

Updated

13 years ago
Attachment #150734 - Flags: review?(mscott) → review-
(Assignee)

Comment 6

13 years ago
fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.