[DOGFOOD] [REGRESSION] password boxes showing passwords

VERIFIED FIXED in M13

Status

()

Core
HTML: Form Submission
P1
critical
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: holi, Assigned: Bill Law)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
With build 2000011508win32, go to any pages with a form with a password field,
and instead of having the usual **** you see the real password (ie. characters
and numbers).

Comment 1

18 years ago
Same problem under Linux with http://slashdot.org/

Build ID: 2000011508 Linux

Updated

18 years ago
Severity: normal → critical
Summary: password boxes showing passwords → [DOGFOOD] password boxes showing passwords
Nominated as [DOGFOOD] and u/ged to critical, seeing as I think people wouldn't
want to use a browser daily if this bug was present ;-)

Gerv

Updated

18 years ago
Assignee: karnaze → buster

Comment 3

18 years ago
Reassigning to Steve.

Updated

18 years ago
Status: NEW → ASSIGNED
Priority: P3 → P1
Summary: [DOGFOOD] password boxes showing passwords → [DOGFOOD] [REGRESSION] password boxes showing passwords
Target Milestone: M13

Comment 4

18 years ago
this sounds like a serious regression.  I know of no code that's changed on my
end to cause this.  I'll look into it asap.

Comment 5

18 years ago
*** Bug 24135 has been marked as a duplicate of this bug. ***

Updated

18 years ago
OS: other → All
Hardware: PC → All

Comment 6

18 years ago
all OS's, as expected.
This is something that the editor handles, not the frame.  Do any of you on
the cc list know of any code which may have changed in the past few days to
cause this?  Pulling a new tree now...

Comment 7

18 years ago
looking into whether this shows up in my build, in case it's me...

Updated

18 years ago
Assignee: buster → jfrancis
Status: ASSIGNED → NEW

Comment 8

18 years ago
yeah, this is all my fault.  fix igoing in soon...

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 9

18 years ago
fixed

Updated

18 years ago
Status: RESOLVED → REOPENED

Comment 10

18 years ago
Waterson sez, of a current build:

HTML forms and password dialogs no longer display the '*' character.
Instead, they display exactly what you type.

This is a great feature: I always used to miskey my password! No more
"Invalid Login, Please Try Again"!

chris

Updated

18 years ago
Resolution: FIXED → ---

Comment 11

18 years ago
*** Bug 24155 has been marked as a duplicate of this bug. ***

Comment 12

18 years ago
I misspoke on IRC today. I am seeing stars in the password -dialogs-, but not in
regular password -text fields- on web pages (e.g., bugzilla's login). Not sure
if this is the same problem or not.

Comment 13

18 years ago
this is all very confusing.  password text fields were working in my tree when i
checked in.  i wonder if different people have been independently causing the
same bug...

Comment 14

18 years ago
Hmmm I can't reproduce this in my 01/18/2000 WinNt build either. I see stars in
the mail password dialog, password field in an HTML form, and in bugzilla's
login page.

Comment 15

18 years ago
Adding myself to the CC list.

Spoke with waterson by phone. He will see if he can reproduce this with his
build from today.

Updated

18 years ago
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 16

18 years ago
Yeah, this works for me today. Marking as FIXED.

Comment 17

18 years ago
On Linux build 2000.01.24.08:

The htaccess password dialog is a grey window, with a blinking caret, no text
boxes.  After I click close to the caret, the user ID box has focus, and I can
type.  After I start typing, the white box and the typed text appears.  To enter
the password, I have to click where the password field would ordinarily be; at
most one "*" is displayed.  No field labels, or "OK", "Cancel" buttons are
displayed.  POP server password dialog works fine.
Status: RESOLVED → REOPENED

Comment 18

18 years ago
Clearing FIXED resolution due to reopen.
Resolution: FIXED → ---

Comment 19

18 years ago
I just realized that this bug was originally for password form fields. I have no
trouble with the form fields, just with the htaccess password dialog. If it's
not related, let me know, and I'll file a separate bug.

Comment 20

18 years ago
this is not the same bug.  I suspect bad xul for the dialog.  Bill?  Should this 
go to you?  Please forward to whoever is appropriate if you are not the right 
person...
Assignee: jfrancis → law
Status: REOPENED → NEW

Comment 21

18 years ago
Per today's PDT - 

Marking FIXED, please set up a new bug for the htaccess problem AND a testcase 
for it in the new bug.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 22

18 years ago
Filed bug 24938, against XUL.

Comment 23

18 years ago
Marking VERIFIED FIXED on:
- Linux6 2000-02-01-10 Commercial build
- Win98 2000-02-01-08 Commercial build
- MacOS86 2000-02-01-09 Commercial build
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.