Improper handling of backslash "\" in URL or links

RESOLVED DUPLICATE of bug 64488

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 64488
14 years ago
6 years ago

People

(Reporter: Tudor Constantinescu, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

When Firefox meets a backslash in URL (typed in "Address" or being a link in
page), it treats it as a special character "%5C". I'm not sure how
standard-complaint is, but I think it should be replaced with a normal slash
"/". That's the way IE manages this issus and seems to be ok.

Reproducible: Always
Steps to Reproduce:
1. Go to: http://web.ss.pub.ro/~ian/School/School_index.html
2. Click on "Tema 01 de laborator" link.
3. The URL Firefox in now looking for should be:
   http://web.ss.pub.ro/~ian/School/IE\Tema01_IE\tema01_IE.html
4. The Firefox tries insted:
   http://web.ss.pub.ro/~ian/School/IE%5CTema01_IE%5Ctema01_IE.html
5. The page really exists at:
   http://web.ss.pub.ro/~ian/School/IE/Tema01_IE/tema01_IE.html
Actual Results:  
The requested URL /~ian/School/IE\Tema01_IE\tema01_IE.html was not found on this
server.

Expected Results:  
It should replace "\" with "/":
http://web.ss.pub.ro/~ian/School/IE/Tema01_IE/tema01_IE.html

Ok, I agree it's a desing fault to write links using "\", but you could
compensate very easy...

Comment 1

14 years ago
Mozilla is doing what it's supposed to do.

IE is the one not really handling the backslash correctly.  Or you could say,
it's hiding the user's error by auto-changing it silently.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> Mozilla is doing what it's supposed to do.

  It was just a proposal...


> IE is the one not really handling the backslash correctly.  Or you could say,
> it's hiding the user's error by auto-changing it silently.

  I agree, but this "silent change" doesn't violate anything, just make IE more
fault-tolerant...

Updated

14 years ago
Status: RESOLVED → VERIFIED
*** Bug 272280 has been marked as a duplicate of this bug. ***

Updated

6 years ago
Status: VERIFIED → RESOLVED
Last Resolved: 14 years ago6 years ago
Resolution: INVALID → DUPLICATE
Duplicate of bug: 64488
You need to log in before you can comment on or make changes to this bug.