Multiple characters are typed in the URL field

RESOLVED DUPLICATE of bug 241447

Status

()

--
major
RESOLVED DUPLICATE of bug 241447
15 years ago
15 years ago

People

(Reporter: jongampark, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040423 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040423 Firefox/0.8.0+

When you type quickly into the URL field with recent nightlies, what you typed
is typed into the field multiple times.


Reproducible: Always
Steps to Reproduce:
1. Click on the URL field
2. Type something quickly, for example, www.google.com
3. Then what you have is ..  wwwwww.gooooglle.coom or something like that.

Actual Results:  
See above

Expected Results:  
www.google.com

Comment 1

15 years ago
I'm seeing that bug too since the last few official builds and also in current
BEAST's build (20040427, win2k).

In deed, characters typed in the location bar appear exactly twice and has
nothing to do at all with the speed of your typing.

Real life example:
when typing 'this is a really annoying bug' in location bar, the outcome is
'thiss is a realllyy annoyying bbug'.

I was able to reproduce the bug when running an instance of firefox for a longer
period (2 hours or so), having some tabs (<10) in use. The bug is gone after
restarting firefox. Extensions + themes disabled.

I think the summary should be adjusted to contain keywords such as "location
bar" etc. (if this isn't a duplicate...).

Comment 2

15 years ago
Tracking it down a little bit more, I found out that the problem is FLASH.

Whenever visiting a site with some flash animation, the bug is there.
Everything is OK again if you close the tab containing the flashy website.

By the way, the bug also affects the "web search" field.
Not confirmed on Linux.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a) Gecko/20040426 Firefox/0.8.0+
(daihard: XFT+GTK2; opt. for P4/SSE-2)

I went to a Flash-heavy site and pounded on the keyboard for a while, spilling
gibberish into the URL bar, and there was no character duplication.

Comment 4

15 years ago
All others text inputting field would have the same problem, too. Don't seems to
be flash problem. But no idea for reproducing the problem.

Comment 5

15 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a) Gecko/20040426 Firefox/0.8

Only occurs when a site utilizing flash is open. Otherwise no problems. Affects
search field as well

Comment 6

15 years ago
I believe I'm seeing this happen using several recent nightlies as well.  

However I'm noticing the character duplication in form fields as well as the
location bar.  Dismissed th first time i noticed as my keyboard being odd but
i'm seeing the problem fairly consistently on WinXP Pro w/ 4-20 and 4-26 builds

Comment 7

15 years ago
Yes, I'm seeing this also with Linux.  The only time I saw this was on the
www.tvguide.com site while completeing a form.  tvguide.com is pretty heavy with
flash.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a) Gecko/20040424 Firefox/0.8.0+
On behalf of comment 7 marking OS -> ALL.

Confirmed with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a)
Gecko/20040427 Firefox/0.8.0+

This bug appears after visiting a page containing flash content. Open the URL
and type some letters very fast inside the input field "PLZ oder Ort". Now the
same bug appears in the location bar for that tab until it is closed.
*** Bug 241881 has been marked as a duplicate of this bug. ***

*** This bug has been marked as a duplicate of 241447 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.