M17rc1 crash importing Outlook address book [@ nsOutlookMail::CreateList]

RESOLVED DUPLICATE of bug 229401

Status

SeaMonkey
MailNews: Address Book & Contacts
--
critical
RESOLVED DUPLICATE of bug 229401
14 years ago
6 years ago

People

(Reporter: jay, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({crash, topcrash})

Other Branch
x86
Windows XP
crash, topcrash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

14 years ago
Many users have been crashing with Mozilla 1.7 beta and rc1 trying to import
their Outlook address books into Mozilla Mail.  User comments mention all
different versions of Outlook on various Windows versions.

Here is the latest from Talkback for rc1:
15   nsOutlookMail::CreateList   14 

 
 	Source File :
d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/mailnews/import/outlook/src/nsOutlookMail.cpp
line : 1081
 
====================================================================================================
     Count   Offset    Real Signature
[ 3   nsOutlookMail::CreateList ed019b18 - nsOutlookMail::CreateList ]
[ 1   nsOutlookMail::CreateList b8aa5245 - nsOutlookMail::CreateList ]
[ 1   nsOutlookMail::CreateList 4d4ca972 - nsOutlookMail::CreateList ]
 
     Crash date range: 22-APR-04 to 26-APR-04
     Min/Max Seconds since last crash: 142 - 21136
     Min/Max Runtime: 753 - 21136
 
     Count   Platform List 
     5   [Windows NT 5.0 build 2195]   
 
     Count   Build Id List 
     5   2004042109
 
     No of Unique Users         4
 
 Stack trace(Frame) 

	 nsOutlookMail::CreateList
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/mailnews/import/outlook/src/nsOutlookMail.cpp
 line 1081] 
	 nsOutlookMail::ImportAddresses
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/mailnews/import/outlook/src/nsOutlookMail.cpp
 line 1012] 
	 ImportOutlookAddressImpl::ImportAddressBook
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/mailnews/import/outlook/src/nsOutlookImport.cpp
 line 627] 
	 ImportAddressThread
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/mailnews/import/src/nsImportAddressBooks.cpp
 line 927] 
	 _PR_NativeRunThread()  
	 _PR_MD_CREATE_THREAD()  
	 MSVCRT.DLL + 0x85bc (0x780085bc)  
	 KERNEL32.DLL + 0x438b (0x7c57438b)   
 
     (30972)	Comments: I was trying to import my contact list from Outlook when
the program crashed.
     (27728)	Comments: importing address book from outlook and got access
violation  outlook was open at the time.
     (27487)	Comments: attempting to import mail from outlook 2002 using wizard
built-in to mozilla.  this feature has never worked using 1.6 and 1.7
 
====================================================================================================
     Count   Offset    Real Signature
[ 3   nsOutlookMail::CreateList 62b100f6 - nsOutlookMail::CreateList ]
 
     Crash date range: 25-APR-04 to 26-APR-04
     Min/Max Seconds since last crash: 75 - 179
     Min/Max Runtime: 138 - 213
 
     Count   Platform List 
     2   [Windows 98 4.10 build 67766446]   
     1   [Windows NT 5.0 build 2195]   
 
     Count   Build Id List 
     3   2004042109
 
     No of Unique Users         2
 
 Stack trace(Frame) 

	 nsOutlookMail::CreateList
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/mailnews/import/outlook/src/nsOutlookMail.cpp
 line 1081] 
	 nsOutlookMail::ImportAddresses
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/mailnews/import/outlook/src/nsOutlookMail.cpp
 line 1012] 
	 ImportOutlookAddressImpl::ImportAddressBook
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/mailnews/import/outlook/src/nsOutlookImport.cpp
 line 627] 
	 ImportAddressThread
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/mailnews/import/src/nsImportAddressBooks.cpp
 line 927]  
 
 
====================================================================================================
     Count   Offset    Real Signature
[ 2   nsOutlookMail::CreateList 078f15ce - nsOutlookMail::CreateList ]
 
     Crash date range: 24-APR-04 to 26-APR-04
     Min/Max Seconds since last crash: 73 - 49752
     Min/Max Runtime: 1179 - 49752
 
     Count   Platform List 
     2   [Windows NT 5.1 build 2600]   
 
     Count   Build Id List 
     2   2004042109
 
     No of Unique Users         2
 
 Stack trace(Frame) 

	 nsOutlookMail::CreateList
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/mailnews/import/outlook/src/nsOutlookMail.cpp
 line 1081] 
	 nsOutlookMail::ImportAddresses
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/mailnews/import/outlook/src/nsOutlookMail.cpp
 line 1012] 
	 ImportOutlookAddressImpl::ImportAddressBook
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/mailnews/import/outlook/src/nsOutlookImport.cpp
 line 627] 
	 ImportAddressThread
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/mailnews/import/src/nsImportAddressBooks.cpp
 line 927] 
	 _PR_NativeRunThread()  
	 _PR_MD_CREATE_THREAD()  
	 msvcrt.dll + 0x27fb8 (0x77c37fb8)  
	 kernel32.dll + 0x1d33b (0x77e7d33b)   
 
     (30749)	Comments: trying to import my Outlook Address book into mozilla mail
     (29514)	Comments: importing outlook address book
 
====================================================================================================
     Count   Offset    Real Signature
[ 1   nsOutlookMail::CreateList 7f1e1140 - nsOutlookMail::CreateList ]
[ 1   nsOutlookMail::CreateList 1240d3bd - nsOutlookMail::CreateList ]
 
     Crash date range: 25-APR-04 to 27-APR-04
     Min/Max Seconds since last crash: 54 - 111
     Min/Max Runtime: 54 - 290
 
     Count   Platform List 
     2   [Windows NT 5.0 build 2195]   
 
     Count   Build Id List 
     2   2004042109
 
     No of Unique Users         2
 
 Stack trace(Frame) 

	 nsOutlookMail::CreateList
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/mailnews/import/outlook/src/nsOutlookMail.cpp
 line 1081] 
	 nsOutlookMail::ImportAddresses
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/mailnews/import/outlook/src/nsOutlookMail.cpp
 line 1012] 
	 ImportOutlookAddressImpl::ImportAddressBook
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/mailnews/import/outlook/src/nsOutlookImport.cpp
 line 627] 
	 ImportAddressThread
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/mailnews/import/src/nsImportAddressBooks.cpp
 line 927] 
	 _PR_NativeRunThread()  
	 _PR_MD_CREATE_THREAD()  
	 MSVCRT.DLL + 0x60ce (0x780060ce)  
	 KERNEL32.DLL + 0x16523 (0x77e96523)   
 
     (31478)	Comments: IMPORTING ADDRESS BOOK FROM OUTLOOK
 
====================================================================================================
     Count   Offset    Real Signature
[ 1   nsOutlookMail::CreateList 75ebfa6e - nsOutlookMail::CreateList ]
 
     Crash date range: 27-APR-04 to 27-APR-04
     Min/Max Seconds since last crash: 27 - 27
     Min/Max Runtime: 471 - 471
 
     Count   Platform List 
     1   [Windows NT 5.1 build 2600]   
 
     Count   Build Id List 
     1   2004042109
 
     No of Unique Users         1
 
 Stack trace(Frame) 

	 nsOutlookMail::CreateList
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/mailnews/import/outlook/src/nsOutlookMail.cpp
 line 1081] 
	 nsOutlookMail::ImportAddresses
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/mailnews/import/outlook/src/nsOutlookMail.cpp
 line 1012] 
	 ImportOutlookAddressImpl::ImportAddressBook
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/mailnews/import/outlook/src/nsOutlookImport.cpp
 line 627] 
	 ImportAddressThread
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/mailnews/import/src/nsImportAddressBooks.cpp
 line 927] 
	 _PR_NativeRunThread()  
	 _PR_MD_CREATE_THREAD()  
	 msvcrt.dll + 0x27fb8 (0x77c07fb8)  
	 kernel32.dll + 0x1d33b (0x77e5d33b)   
 
 
====================================================================================================
     Count   Offset    Real Signature
[ 1   nsOutlookMail::CreateList 4c9b812e - nsOutlookMail::CreateList ]
 
     Crash date range: 27-APR-04 to 27-APR-04
     Min/Max Seconds since last crash: 1703 - 1703
     Min/Max Runtime: 1703 - 1703
 
     Count   Platform List 
     1   [Windows NT 4.0 build 1381]   
 
     Count   Build Id List 
     1   2004042109
 
     No of Unique Users         1
 
 Stack trace(Frame) 

	 nsOutlookMail::CreateList
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/mailnews/import/outlook/src/nsOutlookMail.cpp
 line 1081] 
	 nsOutlookMail::ImportAddresses
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/mailnews/import/outlook/src/nsOutlookMail.cpp
 line 1012] 
	 ImportOutlookAddressImpl::ImportAddressBook
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/mailnews/import/outlook/src/nsOutlookImport.cpp
 line 627] 
	 ImportAddressThread
[d:/BUILDS/tinderbox/Mozilla1.7/WINNT_5.0_Clobber/mozilla/mailnews/import/src/nsImportAddressBooks.cpp
 line 927] 
	 _PR_NativeRunThread()  
	 _PR_MD_CREATE_THREAD()  
	 MSVCRT.dll + 0x60ce (0x780060ce)  
	 KERNEL32.dll + 0x4ef0 (0x77f04ef0)   
 
     (32137)	Comments: importing (converting) address book from Outlook


I personally don't use Outlook, but my Outlook Express addresses were imported
successfully with no crash using Mozilla 1.7 rc1 on WinXP.

Comment 1

14 years ago
maybe the same as bug 229401 ?
(Reporter)

Comment 2

14 years ago
Thanks Bernard.  Marking dup.

*** This bug has been marked as a duplicate of 229401 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
Crash Signature: [@ nsOutlookMail::CreateList]
You need to log in before you can comment on or make changes to this bug.