mpeg/avi attachments show the right size file but are saved/activated with truncated size

RESOLVED DUPLICATE of bug 92111

Status

RESOLVED DUPLICATE of bug 92111
15 years ago
14 years ago

People

(Reporter: finkelg, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040421
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040421

I did not check all options But you can try this for sure:
When ever I open an mpeg file movie the movie is trancated.
If I save the file I see it oly saved 1700Kb from the original 2400Kb
If I use OutLook to view this file It can be saved/viewed correctly.
This seems to happen starting frmo netscape 7.1 version (and Mozilla 1.7rc and
the thunderbird)
I have somthing simiilar with big (~3Mb) avi files (If I ask people to send it
zipped every thing is ok (although the size of the file is not smaller)
I ssupect somthing with the avi/mpeg file save attachment feature is wrong 

Reproducible: Always
Steps to Reproduce:
1. open an mpeg file attacment(I am not sure if the size meter I used 2400Kb file)
2. The player does not show the end of the movie
3. If you save the file localy you see it is not saved in the size of the
original file 

Actual Results:  
file size when saved is too small


Expected Results:  
the original file size should be the same when saved

I have tested the bug on a brend new windows2k sp4 comuter (both prof and server)
(Reporter)

Comment 1

15 years ago
I use the mail client over IMAP protocol connected to our exchange server

Comment 2

14 years ago
I'm seeing the same problem in trying to save an gzipped attachment that is
229046 bytes in size when running TB 0.7.1 on Windows 2000 Pro using IMAP. The
file is either not created or created with a 0 byte size.

NS Trace shows "11 UID fetch 200 (BODY[3])", following by the encoded gzipped
file, followed by a received "11 OK UID FETCH completed".
Seems to be same problem as Bug 243548.
See Bug 243548 Comment #2.

Comment 4

14 years ago
Bug 243548 was duped to bug 249195.  That bug has been marked Fixed (Moz & TB 
nightlies, and will be in Moz 1.7.3) but there are additional problems reported 
there.

Comment 5

14 years ago
This bug is more likely a dupe of bug 92111/bug 105606.  Gilad Finkelstein, if 
you agree, please mark this as a dupe.
Summary: mpeg/avi attachments show the right size file but are saved/activated with trancated size → mpeg/avi attachments show the right size file but are saved/activated with truncated size

Comment 6

14 years ago
No response from reporter, duping.

*** This bug has been marked as a duplicate of 92111 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.