Closed Bug 242439 Opened 19 years ago Closed 19 years ago

submit does not work

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

x86
Windows 2000
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 242494

People

(Reporter: Peter6, Assigned: bryner)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040423 Firefox/0.8.0+ (JTw)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a) Gecko/20040503 Firefox/0.8.0+

the submit button does not work

Reproducible: Always
Steps to Reproduce:
1.open http://www.planet.nl/
2.go to the top-right (login) and push on the arrow (submit button)
3.open the javascript console
Actual Results:  
2 messages in javascript console:
Error: [Exception... "Component returned failure code: 0x8000ffff
(NS_ERROR_UNEXPECTED) [nsIPrefBranch.getBoolPref]"  nsresult: "0x8000ffff
(NS_ERROR_UNEXPECTED)"  location: "JS frame ::
file:///C:/programmas/ff/beast/firefox/components/nsBackgroundUpdateService.js
:: anonymous :: line 252"  data: no]
Source File:
file:///C:/programmas/ff/beast/firefox/components/nsBackgroundUpdateService.js
Line: 252

Error: uncaught exception: [Exception... "Component returned failure code:
0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getBoolPref]"  nsresult:
"0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame ::
file:///C:/programmas/ff/beast/firefox/components/nsBackgroundUpdateService.js
:: anonymous :: line 252"  data: no]

and the submit button does nothing.
It makes no difference if login and password are filled in or not, nothing happens.

Expected Results:  
It should open the webmail page at my provider, like in all FB/FF versions I
used till now.
It still works in the unofficial branch build of 20040423 but does not work in
the 20040503 trunk build.
I don't know any date it first started because I never use trunk builds

This would prevent me from using FF because I need to access my webmail.
I found out the javascript console message had nothing to do with it.
It was gone in latest nightly,

The submit however does NOT work.
Tried seamonkey trunks
the submit is:
OK in /mozilla.org/mozilla/nightly/2004-04-30-10-trunk/
broken in /mozilla.org/mozilla/nightly/2004-05-01-10-trunk/
Assignee: bugs → events
Component: Software Update → Event Handling
Product: Firefox → Browser
QA Contact: bugs → ian
Version: unspecified → Trunk
This bug showed up with the 20040501 nightly build.  I am also experiencing it
at the following URL: http://mail.atl.devry.edu/servlet/webacc.  If I open the
javascript console and click the Login button I get no error messages and
nothing happens. If I click the Help button, however, the help window opens and
I get the same javascript error messages as listed above.
Summary: submit does not work -JSconsole nsBackgroundUpdateService.js :: anonymous :: line 252" data: no → submit does not work
Happens for me too. Can't even use Firefox to login to bugzilla.
Same as bug 242709. Closing as a duplicate of that one because it has a simple
test case some analysis.

*** This bug has been marked as a duplicate of 242709 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
My mistake. The same checkin created this bug and bug 242709, but the testcases
are slightly different and the mechanism of breakage is slightly different as
well. Reopening. Note this is almost certainly the same as bug 242494 (which has
a much simpler, though still external, testcase).
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Assignee: events → bryner
Status: REOPENED → NEW
Blocks: 242494
Yes, same as bug 242494. Closing in favor of that bug because it's easier to
tell what's happening in its test case.

*** This bug has been marked as a duplicate of 242494 ***
No longer blocks: 242494
Status: NEW → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → DUPLICATE
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.