visibility: collapse do not collapse COLGROUP

RESOLVED WORKSFORME

Status

()

Core
Layout: Tables
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Gérard Talbot, Unassigned)

Tracking

({css2, testcase})

Trunk
x86
Windows XP
css2, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

4.33 KB, text/html
Details
(Reporter)

Description

14 years ago
While checking a few things about bug 76497, I noticed that colgroups do not get
collapsed nor get hidden. Note that MSIE 6 for Windows will hide a colgroup
thanks to the css rule 
#idColgroup {visibility: hidden;}

Mozilla 1.8alpha 2004050108 under XP Pro here.

Simple testcase coming up.
(Reporter)

Comment 1

14 years ago
Created attachment 147585 [details]
Simple testcase

Expected results: 
2nd colgroup should get hidden while the 4th colgroup (which has 3 columns)
should get collapsed.

Actual results I get with 1.8a build 2004050108: 
2nd colgroup is visible while 4th colgroup gets hidden.

Comment 2

14 years ago
could you please explain why it should be hidden. I can see collapsed in  the
CSS2.1 spec but not hidden.
visibility:hidden should have no effect on columns or column groups.

Comment 4

14 years ago
I think thats a border collapse painting issue. The columns collapse only the bc
code paints the old borders
(Reporter)

Comment 5

14 years ago
Sorry about that. I thought visibility: hidden should have an effect on col and
colgroups. I modified the summary to reflect that change.
Summary: visibility: collapse and visibility: hidden do not collapse nor hide COLGROUP → visibility: collapse do not collapse COLGROUP
(Reporter)

Comment 6

14 years ago
Created attachment 147662 [details]
Corrected testcase
Attachment #147585 - Attachment is obsolete: true
(Reporter)

Comment 7

14 years ago
I'm resolving this bug as WORKSFORME since bug 242997 and bug 242998 better
describe and better explain what needs to be done and what the problem is.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.