Filter message on To: or Cc: fields is not possible using Address Book entries

RESOLVED DUPLICATE of bug 187768

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED DUPLICATE of bug 187768
14 years ago
14 years ago

People

(Reporter: bmc, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.6) Gecko/20040405 Firefox/0.8
Build Identifier: Mozilla Thunderbird version 0.6 (20040502)

When creating a new message filter (Tools -> Message Filters -> New), and
choosing the To: or Cc: field matches, the choice « is/isn't in my address book
» are not proposed, whereas they are for the From: field.
However, it's useful when you have some contacts that are in multiple Address
Books (e.g. friends with who you work. Yes, indeed, that may happen), and others
not ; filter on the From: field is, in that case, ambiguous.

Reproducible: Always
Steps to Reproduce:
1. Create a new message filter (Tools -> Message Filters... -> New) ;
2. Select the To: or Cc: field for matching ;
3. Try to select the type of matching you want, there's no Address Book entry
picking.
Actual Results:  
From a user's point of view (not algorithmically speaking), ambiguous filtering
when exposed conditions are fulfilled.

Expected Results:  
Propose Address Book entries for filtering on To: or Cc: fields.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 187768 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.