Refresh page while viewing "Print Preview" re-renders the screen output and makes the print preview toolbar unclosable

RESOLVED DUPLICATE of bug 126719

Status

()

defect
--
major
RESOLVED DUPLICATE of bug 126719
15 years ago
15 years ago

People

(Reporter: signup, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

When print preview is accessed on any page, the page can still be refreshed
using the shortcut key "F5". When this is pressed, the page reloads and is
displayed as for normal screen display, rather than the generated print preview.

Additionally, after this refresh occurs the "Close" button in the Print Preview
toolbar does not close the Print Preview toolbar, though it does appear to
redisplay the Tabs toolbar. It makes it impossible to recover the normal web
browser controls and menus. Controls such as the "Portrait" and "Landscape"
buttons, the scale drop down and the "Page 1 of 2" controls become entirely
unresponsive.

Reproducible: Always
Steps to Reproduce:
1. Open any web page (the supplied example is simple and XHTML & CSS compliant
for technical correctness)
2. Open "Print Preview" (File -> Print Preview)
3. Focus on the previewed page and press "F5" for refresh.

Actual Results:  
The original (non-print preview) page is displayed, the print preview toolbar
becomes unclosable.

Expected Results:  
Refresh should have no effect on Print Preview, or alternative should prompt:
"Do you wish to leave Print Preview and refresh this page?", and on consent
should close the Print Preview toolbar before refreshing the page.

Additionally, the "Close" button on the Print Toolbar should not lose functionality.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 126719 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.