CTRL+R (F5) reloads page in the print preview window

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
17 years ago
11 years ago

People

(Reporter: alexsavulov, Unassigned)

Tracking

({helpwanted, regression})

Trunk
Future
helpwanted, regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.4.2 -
blocking1.6 -
blocking1.7a -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
I like the new print preview window, is very cool. (particulary the zoom
function is super)

There's a small problem:
 CTRL+R reloads the page and displays in the print preview window. 

I used to use Ctrl+R to get out of the print preview mode in the previous
builds. Now the new p.p. window has a close button. I think that a shortcut
would be nice to have too.

(now i know what changed so that the crash reported on 126490 WFM now :-)

Comment 1

17 years ago
I think this is a UI issue
Assignee: rods → sgehani

Comment 2

17 years ago
-> Future, helpwanted
Keywords: helpwanted
Target Milestone: --- → Future

Comment 3

17 years ago
Using Build ID: 2002031903 I see this. The odd thing is that once you hit
Ctrl-R, you are back in "browser mode," but you still get the print preview bar
on top. In print preview, Ctrl-R should either do nothing; or reload the current
page and go back to "browser mode." 

Comment 4

17 years ago
This now only happends in the Landscape layout.

Updated

17 years ago
Keywords: mozilla1.0.1, nsbeta1

Comment 5

17 years ago
Nav triage team: nsbeta1-
Keywords: nsbeta1 → nsbeta1-

Updated

17 years ago
Keywords: mozilla1.0.1 → mozilla1.3

Comment 6

17 years ago
*** Bug 175471 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
If you are browsing using several tabs in the same window, it is not possible to
access the other tabs after this bug has occurred.

The contents of the other tabs are thus lost. This is rather annoying.

Comment 8

17 years ago
I confirm part of the previous comment on a recent 1.3a nightly build.

After Ctrl+R on a print preview window, where there are multiple tabs, the
"close" button" stops working. Closing the window itself results not in a
reversion to normal mode from print preview mode, but the closing of the entire
browser window.

Workaround: Ctrl+Tab still allows you to access multiple tabs, but only in print
preview mode. 

Increasing severity to major.

This bug is symptomatic of a larger problem. I think we should implement print
preview in a separate window, like IE does. See bug 133787.
Severity: normal → major

Comment 9

17 years ago
this happens in 1.3a for mac os x, as well.

Updated

17 years ago
OS: Windows 2000 → All
Hardware: PC → All
*** Bug 190599 has been marked as a duplicate of this bug. ***
*** Bug 191296 has been marked as a duplicate of this bug. ***
*** Bug 192252 has been marked as a duplicate of this bug. ***
*** Bug 195231 has been marked as a duplicate of this bug. ***
seeing the same on W2k with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.3b) Gecko/20030210

but I can´t confirm comments #7 and #8. After reloading print preview with
Ctrl+R or F5 and clicking on close with multiple tabs opened, everything works
again as expected except the one tab I opened in print preview. There every try
to change the url of the tab results in the error message "the document cannot
change while Printing or in Print Preview".

To resolve this and get Mozilla to work as expected, one can use the following
workarounds: 

1. Open the print preview of the affected tab and close print preview again and
the tab works as expected.

2. Click on Print after reloading Print Preview and
a) simply print the page. The menu bar of print preview vanishes and everthing
works as expected
b) after clicking on chancel in printing dialog and on close in the print
preview menu bar. Here again everything is okay afterwards.

Updated

16 years ago
Keywords: mozilla1.3

Comment 15

16 years ago
I reload print preview window in Moz1.3 release and press Close button. When I
type new location, Moz alerted to me "The document cannot change while Printing
or Print Preview".

Comment 16

16 years ago
*** Bug 203654 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Blocks: 193579

Comment 17

16 years ago
This bug is assigned to Samir, does the still work at Netscape? Should it be
reassigned to default owner of the component?

Comment 18

16 years ago
*** Bug 209196 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Summary: CTRL+R reloads page in the print preview window → CTRL+R (F5) reloads page in the print preview window

Comment 19

16 years ago
I'm adding my comments from my other bug because they show another side to this bug.

-----------------

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b)
Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b)
Gecko/20030507

In print preview mode Mozilla allows refreshing via F5 (or ctrl + r).  Once this
is done, closing print preview does not allow you to change the page.  Instead
it gives you an error about not changing pages in print preview mode.

Reproducible: Always

Steps to Reproduce:
1. Go to any webpage
2. File -> Print Preview
3. Press F5 to refresh the page, it will redraw the page
4. Close the print preview
5. Navigate to any new webpage

Actual Results:  
An error is produced stating that the page cannot change while in print or print
preview mode.

Expected Results:  
1. Not allow a page refresh in print preview mode

or 

2. Allow a refresh, but still allow navigation after the print preview mode
*** Bug 223946 has been marked as a duplicate of this bug. ***
*** Bug 227648 has been marked as a duplicate of this bug. ***

Comment 22

16 years ago
This attachment shows that "refresh" in the print preview takes you out of
print preview mode by using CSS's @media property.

To get the effect, load the attachment in your browser as a page.  Then go to
print preview.	While in print preview, reload the page by any of the following
methods:
Ctrl-R
F5
Right-click/select Reload

The @media type changes from print to screen.  The only way out is to close the
browser window.

I suggest changing the implementation of Print Preview.  IMHO it's hard --
perhaps too hard -- to maintain a dumbed-down version of the HTML rendering
code.  I'd say develop something akin to Mac OS X's "Preview" - that is, print
to a postscript file, render that as a pdf, and display the PDF.  That would
probably eliminate a whole slew of Print Preview bugs related to active
content.

Updated

15 years ago
Flags: blocking1.7a?
Flags: blocking1.6?
Flags: blocking1.4.2?

Comment 23

15 years ago
It goes back to browser mode.
You can select text, follow links, and... if you refresh and close the window,
it loads further in your real browser.

Comment 24

15 years ago
too late for feature redesign work in 1.6
Flags: blocking1.6? → blocking1.6-

Updated

15 years ago
Blocks: 223888

Comment 25

15 years ago
What's strange is:  If I press backspace while in print preview, I get a nice
little popup error msg telling me I can't change the page while in preview mode.  

Would it be very difficult to just point F5 to the same function?  (I'm asking
because I don't know how difficult that would be.)

Without a patch, and no one working on this, not going to hold the release. We'd
consider a patch if someone comes up with one. 
Assignee: sgehani → nobody
Flags: blocking1.7a? → blocking1.7a-

Updated

15 years ago
Flags: blocking1.4.2? → blocking1.4.2-
*** Bug 234807 has been marked as a duplicate of this bug. ***

Comment 28

15 years ago
*** Bug 235955 has been marked as a duplicate of this bug. ***

Comment 29

15 years ago
*** Bug 236475 has been marked as a duplicate of this bug. ***

Comment 30

15 years ago
(In reply to comment #25)
> What's strange is:  If I press backspace while in print preview, I get a nice
> little popup error msg telling me I can't change the page while in preview mode.  

Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7b) Gecko/20040313
Firefox/0.8.0+ (djeter)

Backspace key no longer displays that pop-up message.  It simply has no effect,
which is fine.  

Can whoever changed the action of the backspace key make the same change to the
action of the F5 key?

Comment 31

15 years ago
This bug also exhibits itself in Firefox. Not sure if its the same bug, or if
the code is forked. Not filing a new bug, because I don't know if the code is
forked. UA I tested with:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7b) Gecko/20040317 Firefox/0.8.0+

Comment 32

15 years ago
*** Bug 237702 has been marked as a duplicate of this bug. ***

Comment 33

15 years ago
*** Bug 242180 has been marked as a duplicate of this bug. ***

Comment 34

15 years ago
*** Bug 242547 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Keywords: regression

Comment 35

15 years ago
*** Bug 242996 has been marked as a duplicate of this bug. ***

Comment 36

15 years ago
*** Bug 246396 has been marked as a duplicate of this bug. ***

Comment 37

15 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.7) Gecko/20040615

Using the above build, I now crash when pressing Ctrl+R in Print Preview

Talkback IDs
TB123635Q
TB123707H

Comment 38

15 years ago
*** Bug 250391 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Blocks: 253541

Comment 39

15 years ago
*** Bug 254846 has been marked as a duplicate of this bug. ***
*** Bug 261756 has been marked as a duplicate of this bug. ***

Comment 41

15 years ago
*** Bug 253541 has been marked as a duplicate of this bug. ***

Comment 42

15 years ago
Would like to confirm this for FireFox 0.10.1 (1.0 PR).

Comment 43

15 years ago
This still occurs in Mozilla 1.7.3 Linux x86.

Initially I noticed that hitting ctrl-r in print preview caused the title and
url to disappear from the top of the page.  Then I noticed that closing the
window closed the window I came from.  Since I was print-previewing this bug
submission page at the time, I had to type this text over again.  Grrr.

The previously attached example of bad behaviour still behaves badly.

While testing the bad behaviour attachment, I noticed that when I hit print
preview, the current page is replaced by the print preview page.  If I hit
ctrl-r, the print preview controls are still at the top, but the page itself
looks like it did before I hit print preview.  Hitting the 'close' button is the
same as hitting 'back' on a regular page.

Comment 44

15 years ago
*** Bug 267694 has been marked as a duplicate of this bug. ***
(In reply to comment #42)
> Would like to confirm this for FireFox 0.10.1 (1.0 PR).

Firefox 1.0 Release does this too.  (Mozilla/5.0 (Windows; U; Windows NT 5.1;
en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0)
*** Bug 268316 has been marked as a duplicate of this bug. ***
*** Bug 275443 has been marked as a duplicate of this bug. ***
*** Bug 276751 has been marked as a duplicate of this bug. ***

Comment 49

14 years ago
*** Bug 281420 has been marked as a duplicate of this bug. ***
*** Bug 281675 has been marked as a duplicate of this bug. ***

Comment 51

14 years ago
Confirmed in Firefox (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0)) on Windows XP SP 2.

However, I was not able to get back to the normal browsing mode even after
printing the page.

Comment 52

14 years ago
*** Bug 282751 has been marked as a duplicate of this bug. ***

Comment 53

14 years ago
Bug 282552 is a duplicate of this.
And this bug is still valid in Firefox 1.0.1.

Comment 54

14 years ago
*** Bug 282552 has been marked as a duplicate of this bug. ***
Assignee: nobody → printing
QA Contact: sujay
*** Bug 286331 has been marked as a duplicate of this bug. ***

Comment 56

14 years ago
*** Bug 286577 has been marked as a duplicate of this bug. ***

Comment 57

14 years ago
*** Bug 287249 has been marked as a duplicate of this bug. ***

Comment 58

14 years ago
*** Bug 290973 has been marked as a duplicate of this bug. ***

Comment 59

14 years ago
*** Bug 291422 has been marked as a duplicate of this bug. ***

Comment 60

14 years ago
*** Bug 287691 has been marked as a duplicate of this bug. ***
*** Bug 291449 has been marked as a duplicate of this bug. ***

Comment 62

14 years ago
*** Bug 293218 has been marked as a duplicate of this bug. ***

Comment 63

14 years ago
*** Bug 294465 has been marked as a duplicate of this bug. ***

Comment 64

14 years ago
*** Bug 295330 has been marked as a duplicate of this bug. ***

Comment 65

14 years ago
*** Bug 296837 has been marked as a duplicate of this bug. ***

Comment 66

14 years ago
(In reply to comment #25)
> What's strange is:  If I press backspace while in print preview, I get a nice
> little popup error msg telling me I can't change the page while in preview mode.  
> 
> Would it be very difficult to just point F5 to the same function?  (I'm asking
> because I don't know how difficult that would be.)

Regression in Deer Park Alpha 1:  The backspace key now does bad things in
preview mode.  

Comment 67

14 years ago
*** Bug 296688 has been marked as a duplicate of this bug. ***

Comment 68

14 years ago
*** Bug 297059 has been marked as a duplicate of this bug. ***
*** Bug 297454 has been marked as a duplicate of this bug. ***

Comment 70

14 years ago
*** Bug 297453 has been marked as a duplicate of this bug. ***

Comment 71

14 years ago
*** Bug 299012 has been marked as a duplicate of this bug. ***
This is actually work for me in current trunk build:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050701
Firefox/1.0+
Shouldn't it be marked as such?

Comment 73

14 years ago
WFM too with build 20050702, Windows XP

:-D

Please reopen if you can reproduce with a trunk build
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 74

14 years ago
Actually, after further testing, I noticed that F5 _does_ work. Though for it to
work,  you need to

1. click on the testcase (attachment 137338 [details])
2. Pressing F5 or ctrl+r will do nothing
3. right click witht the mouse a couple of times, no menu appears
5. but now F5 will work and reload

Should that be a new bug?
*** Bug 299530 has been marked as a duplicate of this bug. ***

Comment 76

14 years ago
Bug 299555 filed for the (rare and not easy to reproduce) issue mentioned in
comment 74

Comment 77

14 years ago
It still reproduces. 

Reproducible: Always
Steps to Reproduce:
1. Open page and execute "Print Preview".
2. Focus is moved to the text field that inputs the page number. 
3. Push "F5" key.


Windows XP Pro SP1
Mozilla/5.0 (Windows; U; Windows NT 5.1; ja-JP; rv:1.8b2) Gecko/20050703
Firefox/1.0+
crot0@infoseek.jp, bug 299555 has been filed for that.
*** Bug 300134 has been marked as a duplicate of this bug. ***

Comment 80

14 years ago
Can't exit the preview after the F5
Could be useful to be able to reload the printer view of a page (HTML or CSS
"@media print" changing will developping for exemple)

Comment 81

14 years ago
At least in Firefox 1.0.6, this is still not resolved. Pressing F5 whilst in
Print Preview puts Firefox into a confused state.

Steps to repo:
1) Have multiple tabs open in Firefox.
2) On one of those tabs, go file -> print preview
3) Press the "F5" keyboard key.
4) Press the "close" button.

Observed behaviour: 
See attached screenshot. Note that multiple tabs are showing, AND the print
preview toolbar is showing. Firefox does not seem to know whether it is in
normal multi-tab browsing mode, or in print preview mode. Additionally, only
the "print" and "page setup" buttons on the toolbar seem to do anything (i.e.
all the others, including "Close", do nothing when pressed). Therefore the only
way to get out of this confused state seems to be to close the browser and then
to restart it.

Expected behaviour:
Pressing the F5 keyboard button in print preview mode to do nothing.

Comment 82

14 years ago
(In reply to comment #80)
> Can't exit the preview after the F5

(In reply to comment #81)
> At least in Firefox 1.0.6, this is still not resolved. 

This works fine with trunk builds. It will work as expected in the next major
release (1.5)
*** Bug 303534 has been marked as a duplicate of this bug. ***
*** Bug 303589 has been marked as a duplicate of this bug. ***

Comment 85

14 years ago
*** Bug 303589 has been marked as a duplicate of this bug. ***

Comment 86

14 years ago
*** Bug 303534 has been marked as a duplicate of this bug. ***
*** Bug 304619 has been marked as a duplicate of this bug. ***

Comment 88

14 years ago
*** Bug 305177 has been marked as a duplicate of this bug. ***
*** Bug 306048 has been marked as a duplicate of this bug. ***
*** Bug 312017 has been marked as a duplicate of this bug. ***
*** Bug 315678 has been marked as a duplicate of this bug. ***

Comment 92

14 years ago
*** Bug 317608 has been marked as a duplicate of this bug. ***

Comment 93

13 years ago
Not completely fixed! Bug reappears when page navigation buttons are used.

- open up any webpage
- select "file" > "print preview"
- at the page navigation, use one of the arrows ("next page" for example)
- hit the refresh shortcut (F5, CTRL+R, Cloaverleaf+R, ...)

This bug needs to be reopened...
Bramus, that's bug 299555.

Comment 95

13 years ago
I just found this in Windows XP SP2 with Firefox 1.5.0.7. If I open Print Preview, click Page Setup, then close the setup window and press F5, it breaks the GUI. It looks like the Print Preview window closes, and the original browser window suddenly becomes a mutant browser/preview window, sometimes with the tab bar.

This only seems to happen if I enter Page Setup before pressing F5, which may explain why few people could see it.

Comment 96

13 years ago
If you have a page with a meta refresh that triggers while you are previewing it you end up with an unclosable print preview, the tab bar open, no menu, no status bar and the window contents does not show the print page preview but instead shows the normal browser. You can't do anything to make the preview bar go away.

I'm using Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.8.0.7) Gecko/20060920 Firefox/1.5.0.7, this bug should be reopened.
Duplicate of this bug: 390945

Comment 98

11 years ago
Still half-present in Firefox 3.0 RC1 on Windows XP SP2.
User agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0

Here are some scenarios in which this does and doesn't occur:

Fixed/does not occur, steps:
1. File > Print Preview on any page
2. Press F5, Ctrl+R, or Ctrl+Shift+R
Actual Results: Nothing happens
Expected Results: Same as actual results

Fixed/does not occur, steps:
1. File > Print Preview on any page
2. Click anywhere on chrome
3. Press F5, Ctrl+R, or Ctrl+Shift+R
Actual Results: "The document cannot change while Printing or in Print Preview"
Expected Results: Same as actual results

Unfixed, steps:
1. File > Print Preview on any page
2. Click Print...
3. Continue printing or click Cancel (either way the Print Preview window will remain)
4. Press F5 (Ctrl+R and Ctrl+Shift+R do not reproduce bug)
Actual Results: Reloads page, allows navigation, Close does not work, etc.
Expected Reults: Nothing happens, or alert like the other example.

How about instead of loading the Print Preview in the main window as it is done currently, open it in a new window? That way in the event that it breaks, it can still be closed without disrupting anything else.

Updated

11 years ago
Flags: blocking1.9.1?
Dagosta, please file a new bug for that (and mention the bug number here).

Comment 100

11 years ago
This bug seems to be back. See bug 444843.
Flags: blocking1.9.1?

Comment 101

11 years ago
You need to cancel the print dialog first though on that bug. Confirming that one and leaving this one closed.
You need to log in before you can comment on or make changes to this bug.