Ability to force default theme on startup

RESOLVED DUPLICATE of bug 170006

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 170006
15 years ago
11 years ago

People

(Reporter: gkn, Assigned: benjamin)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8a) Gecko/20040506 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8a) Gecko/20040506 Firefox/0.8.0+

It should be possible to start Firefox without themes and extensions ("Safe
Mode"). This would enable duff extensions or themes to be removed without
file-hacking (assuming the new extension arrangements don't magically take care
of this).

Since themes and extensions will now all be kept in one place, and are organised
so as to be uninstallable, this should be possible.

Also, there could be a Safe Mode program icon.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Startup without any extensions is already covered by bug 170006 and has been
implemented by Ben. I don't know if a no-themes mode is also planned. I'm
marking this a dupe of 170006. Please open a new bug for the no-themes mode.

*** This bug has been marked as a duplicate of 170006 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

15 years ago
Rather than file a new bug, I'm removing the "extensions" part from this bug's
summary (and reopening).
This bug is now about the ability to force Firefox to use the default theme on
startup.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Summary: "Safe Mode" - startup without themes/extensions → Ability to force default theme on startup
Greg Ben's work is to also include Themes install/uninstall down the road,
assuming "disable" as in Bug 170006

Might be easier to leave as "resolved duplicate" IMHO and open a new bug on
themes alone if not one already listed (try searching).

Since in Bug 170006 this is marked as a dupe of it.  Dupes, unless initially
incorrect when marked as such as usually taken as such.

When a bug, which was a Duplicate is resolved, the QA is sopposed to check the
Dup's as well and if any are not resolved they are expected to re-open anyway,
by shear fact that they were resolved as a dupe, and the bug that was resolved
didnt fix.

Hope that helps.
(Reporter)

Comment 4

15 years ago
If Themes is covered by bug 170006 as well as Extensions, this is a dupe of 170006.

*** This bug has been marked as a duplicate of 170006 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.