Closed Bug 170006 Opened 17 years ago Closed 15 years ago

New Extension Manager

Categories

(Toolkit :: Add-ons Manager, enhancement, P1)

x86
All
enhancement

Tracking

()

RESOLVED FIXED
mozilla1.7

People

(Reporter: asa, Assigned: bugs)

References

Details

(Whiteboard: fixed-aviary1.0)

This package manager will allow selective enabling and disabling plugins and
mozilla add-ons.  The manager will also allow for uninstall of specific plug-in
and add-on packages.
shooting for next release. 
Summary: implement add-on and plug-in manager → implement add-on and plug-in manager
Target Milestone: --- → Phoenix0.2
perhaps as a future issue - it would be nice to know in the manager view what
the version is of the plugin or add-on.
Target Milestone: Phoenix0.2 → Phoenix0.3
hyatt is done with this for 0.2.  Enabling/disabling works, uninstallation not yet.
updating summary.
Summary: implement add-on and plug-in manager → implement add-on and plug-in manager uninstall
Target Milestone: Phoenix0.3 → Phoenix0.4
Target Milestone: Phoenix0.4 → Phoenix0.5
Target Milestone: Phoenix0.5 → Phoenix0.6
Severity: normal → enhancement
fwiw, a lot of package uninstalling work has been done in bug 161508 and in bug
114092. The two implementations are stalled, though.
Yes please
maybe 0.7
Target Milestone: Phoenix0.6 → Phoenix0.7
*** Bug 213195 has been marked as a duplicate of this bug. ***
I found exUnregisterer (XUL Package Unregisterer) from piro's site.
http://white.sakura.ne.jp/~piro/xul/lib/exUnregisterer.js
Target Milestone: Firebird0.7 → Firebird0.8
QA Contact: asa
Blocks: majorbugs
Retargeting. This is part of work that is scheduled for 0.10, so I'm targeting
it there. 
Target Milestone: Firebird0.8 → Firebird0.10
*** Bug 231386 has been marked as a duplicate of this bug. ***
Assignee: hyatt → bugs
Priority: -- → P1
Summary: implement add-on and plug-in manager uninstall → New Extension Manager
Target Milestone: Firefox1.0beta → Firefox0.9
No, the extension manager doesn't come into play with bug 238684. But we can
still try to get something done about it.
I have a question, won't rewriting the new extension manager from C++ to js make
it slower. Wouldn't C++ be much faster?
>>This package manager will allow selective enabling and disabling plugins 
>>and mozilla add-ons.  The manager will also allow for uninstall of specific 
>>plug-in and add-on packages.
"Mozilla Add-Ons", do you mean this extension manager will be included in
Mozilla down the road?  Just want some clarification here, that's all.

*** Bug 242811 has been marked as a duplicate of this bug. ***
Status: NEW → ASSIGNED
Flags: blocking0.9+
-> Extension Mgr.
Component: General → Extension/Theme Manager
*** Bug 242811 has been marked as a duplicate of this bug. ***
No longer blocks: 244009
Depends on: 244009
Whiteboard: fixed-aviary1.0
*** Bug 224777 has been marked as a duplicate of this bug. ***
Since FF now has an extension mgr, perhaps this bug should be marked "FIXED"?

Unable to reinstall .9 as extension manager hangs forever when firefox attempts 
to open
> Unable to reinstall .9 as extension manager hangs forever when firefox attempts 
> to open

Source from FireFox 0.9.1 
/mozilla/rdf/chrome/src/nsChromeRegistry.cpp
......
NS_IMETHODIMP nsChromeRegistry::UninstallPackage(const PRUnichar* aPackageName, 
PRBool aUseProfile)
......

They didn't change this file :)
> Source from FireFox 0.9.1 
> /mozilla/rdf/chrome/src/nsChromeRegistry.cpp
> ......
> NS_IMETHODIMP nsChromeRegistry::UninstallPackage(const PRUnichar* aPackageName, 
> PRBool aUseProfile)
> ......
> 
> They didn't change this file :)

That file is not part of the firefox build, it is only built for seamonkey. And
it has nothing to do with the extension manager hanging, which is another bug
that was already fixed (hopefully).

I'm gonna give Ben credit and mark this FIXED ;)
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
No longer blocks: majorbugs
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.