Automatically recognize "Sent Items" and "Deleted Items" and "Spam"

RESOLVED DUPLICATE of bug 558659

Status

MailNews Core
Networking: IMAP
RESOLVED DUPLICATE of bug 558659
14 years ago
6 years ago

People

(Reporter: Alec Flett, Assigned: Bienvenu)

Tracking

Trunk
mozilla1.8beta1
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Outlook and Exchange use the folders "Sent Items" and "Deleted Items" to
represent the trash folder and the Sent folder. FireFox currently creates new
folders, "Trash" and "Sent" instead of automatically recognizing these folders
on the server.

Some Spam add-ons to Exchange create a folder called "Spam" in your folder tree,
and we should recognize that as a substitute for "Junk"

During folder discovery the first time an account is accessed, we should try to
look for these special folder names instead.

Fortunately, exchange/outlook does agree that "Drafts" should be called just that.
(Reporter)

Comment 1

14 years ago
Oh, and for clarification, this is for people who use FireFox to connect to an
Exchange server.

Comment 2

14 years ago
i don't know how easy or hard this is but it would be something David would know. 
Assignee: mscott → bienvenu
Target Milestone: --- → Thunderbird0.8
(Assignee)

Comment 3

14 years ago
People using FireFox to read IMAP mail aren't going to be too successful :-) But
we should be able to improve the Thunderbird experience :-) We do allow you to
override these folder names with a pref, but at that point, it's a little late,
I guess...the sent folder pref is available through the UI - the trash pref is
per-server, and is "trash_folder_name". We could just recognize those special
folder names in general, or we could somehow detect that it's an exchange server
and then detect those folder names..
Component: Mail Window Front End → Networking: IMAP
Product: Thunderbird → MailNews
Target Milestone: Thunderbird0.8 → mozilla1.8beta
Version: unspecified → Trunk
(Reporter)

Comment 4

14 years ago
yeah, I mean setting them in the UI is easy, don't get me wrong. I'm just
looking at an easy user experience right off the bat. Users don't know anything
about IMAP and that "Sent" is a specially flagged folder locally on the client -
for all they can observe, the folder is in fact special, and the client that
doesn't recognize that is dumb.

i.e. Imagine a situation where I'm saying to my coworker "yeah, you should try
thunderbird, its really cool" - they go to do it with their exchange account and
they get all these folders created that duplicate the functionality of existing
folders, and so forth. As an outlook/exchange user, they walk away going
"Thunderbird is really dumb, it doesn't even recognize my folders.." (and that's
just it, they walk away, and back to outlook!)
(Assignee)

Comment 5

14 years ago
yes, that's what I meant by "it's a little too late at that point".

Comment 6

14 years ago
I would say this should be a change request for the new account dialog.  Before
creating the folders for local storage, the setup would need to query the IMAP
server to find out what folders already exist.  If it sees something special
like "spam", "deleted items", "sent items", etc., then it should query the user
whether they want to use those folders for spam/trash/sent.  (However, this
approach assumes that the IMAP server is english, and the app would need to
remember all of the other possible ways that other languages specify the
junk/trash/sent folder names.)

So instead, it should simply get a folder list from the IMAP server, check to
see whether the standard "Trash", "Junk" and "Sent" folders exist.  If those
folders don't exist, then it should prompt the user to pick an existing IMAP
folder or tell the mail application to create those folders.
Product: MailNews → Core

Comment 7

11 years ago
On my Exchange account there's no "Spam" , but a "Junk E-Mail" folder

Comment 8

11 years ago
So is there any solution? Still the problem exists that Thunderbird (even in version 2.0) has created a "Trash" folder in my exchange account and is not using the existing "deleted items". This is not too straight forward.

Furthermore, there is no way in the UI to change the setting for the destination folder for deleted items

any solution??? 
Gmail uses folders "[Gmail]/Sent Mail", "[Gmail]/Trash" and "[Gmail]/Drafts".
Configuring Outlook to do the same, is a bigger problem. Outlook persists in using and creating the folders "Sent Items" and "Deleted Items", even though these are normal labels for Gmail and folders for Thunderbird... And if I use my Dutch Outlook, it will create the folders Verzonden and Verwijderde items.
Outlook Mobile is making it even harder to overrule the folder names (if it's even possible at all). It would be hard to automatically detect if existing folders are special folders.

I think the way Thunderbird handles this and lets the user override the names isn't that bad. And an option to do this from the UI would make it even more usable.
Product: Core → MailNews Core

Updated

9 years ago
QA Contact: networking.imap

Comment 10

6 years ago
The difficulty seems to be that the folder list is not available to Thunderbird until after the account creation is completed and the user actually clicks into the only "Inbox" folder they are presented with.

Steps to reproduce:
Open account settings
Add new account
Configure as required (please see bug 353838 - https://bugzilla.mozilla.org/show_bug.cgi?id=353838 ).
Hit "advanced"

At this point the account has been "created" in Thunderbird, and you can see in the window behind the account settings screen that the account and its Inbox exist.

At this point, if you try to go to the "Server Settings" submenu and edit the "When I delete a folder" preference, the only thing that is available in my case is "Trash", the default. My server uses "Deleted Items"

At this point I have to exit the account settings menu and either click on the account itself or right-click on it and bring up the subscribe menu.

It appears that the very first time Thunderbird connects it will create the default "trash" account.

While this particular bug is an RFE, it appears the "bigger" problem is that, when creating IMAP accounts, Thunderbird does not poll for the folder list so that you can choose your alternate folders, regardless of whether or not it auto detects.

Comment 11

6 years ago
I filed bug 688739 to discuss how the IMAP server should be polled during account creation, so that at least users can select the right folder.

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 558659
You need to log in before you can comment on or make changes to this bug.