Open Bug 353838 Opened 14 years ago Updated 4 months ago

Add ability to create accounts without using wizard

Categories

(Thunderbird :: Account Manager, enhancement)

enhancement
Not set

Tracking

(Not tracked)

People

(Reporter: sheppy, Unassigned)

References

Details

I prefer to hand-configure my accounts.  I'd like to be able to set them up without using a new account wizard.
> I prefer to hand-configure my accounts.

You mean, like, hacking text files?
You can of course edit prefs.js and create everything you need manually, but you really don't want to do this...


No, I mean by simply opening up the Account Manager, adding a blank account, and editing all the form fields there directly instead of having them prepopulated using a wizard.
OS: Mac OS X 10.4 → All
Hardware: Macintosh → All
Version: 1.5 → Trunk
Seamonkey bug 186862.
I'd like to see something like this too.  I'm sure we're not alone: there seems to be a fairly large community of people like me, who are using the ability to autoconfig Thunderbird with javascript files.

My users - including first time users - log in with their primary IMAP mail account fully configured.  First time users are forced to hit "Cancel" on the New Account Setup/Account Wizard dialog.

Having that configurable through the config settings would be a big help.
Anthony, if you're using MCD (aka autoconfig), then the new account wizard shouldn't come up. And if you're using js files to create new accounts (e.g., something in user.js), then if you set the right prefs, the new account wizard shouldn't come up.
    Really?  I'm doing something wrong, then.  Here's our setup, maybe you can point me in the right direction.  It's pretty convoluted.  :\

Red Hat Enterprise Linux WS release 4 (Nahant Update 4)
Thunderbird 1.5.0.9

I've got a file a file called 'vendor.js' in /usr/lib64/thunderbird-1.5.0.9/defaults/pref with the following contents:

pref("general.config.obscure_value", 0);
pref("general.config.filename", "dw-config.cfg");


Here's the contents of 'dw-config.cfg' (in /usr/lib64/thunderbird-1.5.0.9):

#Comment line as the first line in JS files isn't read
lockPref("autoadmin.global_config_url","http://proxyconfig/mozilla-autoconfig/");

    Those two files exist in /usr/lib/firefox-<version> and /usr/lib/mozilla-<version>, too.  They all point to the same URL.
    That location has an index.cgi file: perl code that determines the user agent from HTTP_USER_AGENT and points it to the proper config file for T-bird, Firefox, or Mozilla/Seamonkey, which lives in a subdirectory of that location on the web server.

    That's the part that's messing us up.  According to the docs at http://developer.mozilla.org/en/docs/MCD%2C_Mission_Control_Desktop_AKA_AutoConfig, the full config file is sitting directly in the program directory (i.e., /usr/lib64/thunderbird-1.5.0.9).  When I put the file there, point vendor.js to it, and start T-bird as a new user, the new account wizard doesn't come up - as you say.

    So the problem I'm having is in the "autoadmin.global_config_url": when I point that directly to the file (bypassing the index.cgi) I get the new account wizard again.

    So do I open a new bug?

thx
    anthony
Have you tried 2.0 rc2 or a trunk build? I fixed a bug in this area - see bug 369009
I forgot to say that I'm not sure if that bug existed in 1.5, but I rather think it did.
    I haven't, but I will.  Unfortunately it's unsupported by Red Hat so it's unlikely that we'll roll up studio-wide until that happens (corporate environments :( )

    I'll post my results after I test 2.0 rc2.

thx
    anthony
    Nice.  Fixed like 10 in T-bird 2.0 rc2.  :)  Thanks, David!

thx
    anthony
Thx, Anthony. Please let me know about problems you have with MCD with new builds - we don't use it internally so we mostly rely on our users to report problems with MCD
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 369009
    Can do!

thx
    anthony
I'm not so sure this bug is a dupe. I think Anthony hijacked Eric's bug with another issue :)

Eric is asking for removing the account wizard and having fields filled directly into the account manager panels. I don't think his request is a dupe of the mcd bug 369009.
Yes, Scott's right.  This isn't the same issue at all.  I'm proposing that there be an advanced configuration mode whereby instead of using the wizard you can create an account and configure it manually using the account manager.  Sometimes that's actually easier, especially when setting up email accounts with weird configurations (such as special paths on an IMAP server).
d'uh, sorry.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Assignee: mscott → nobody
Status: REOPENED → NEW
Duplicate of this bug: 552379
Duplicate of this bug: 571483
Duplicate of this bug: 590475
Is there anything new in this matter?
The only thing to do at the moment is to use the MailTweak:

http://mailtweak.mozdev.org/installation.html

and enable "New Mail Account"
This is a poor solution for a program like Thunderbird.
Duplicate of this bug: 596898
Recently I had problems to connect to the mozilla ISP database and was nto able to create a ne account and had to come back a second time to the user to do this job. The wizards must be optional.
Maybe a friendly dialogue window would be nice asking you if you want a wizard to help you or configure the new account manually before the New-account-wirzard is displayed at all.
There is currently an "advanced" mode in 6.0.2. In order to get to it:

Account settings
Add new account
Fill in some mail details (name, email address, password)
Hit continue
Cancel out of the auto-detect by hitting Manual Config
Continue to fill in more details

Then you can actually select advanced.

You should be able to select "Advanced" right from the opening Wizard page.
Duplicate of this bug: 694117
Duplicate of this bug: 596898
If use set Thunderbird into offline mode

File - Offline - work offline

then you can create the account without any tests. Just set it to online again afterwards to receive the mails.
I'm testing an IMAP server setup. So, of course, I need a client in order to test to see if the IMAP server is working. My chosen client was Thunderbird. What a mistake that was!

Because the wizard completely refuses to create an account if it can't talk to a working IMAP server, I could not create an account in Thunderbird for testing. After over half hour of intense frustration trying to click the damned "Manual config" button--and failing--in the approximately 0.2 seconds it took Thunderbird to go into its window where you can't create an account because the IMAP server doesn't work, I threw my wireless mouse across the room. It no longer works.

This is unacceptable. A good user interface should give me a *choice* between a **** auto-setup that may or may not work and a fully manual setup that experienced people can play around with. Currently the only way to get to the manual settings is by a hidden hack where you first put Thunderbird into Offline mode before creating the account. Something I didn't know until I searched for "Thunderbird bug account setup" in DuckDuckGo, read a blog post, and found this bug.

At this point I an thoroughly unimpressed with the Thunderbird development team. This bug has been open for eleven years. Don't assume you know the mind of every user. Sometimes there are reasons people want to bypass the wizards and do things for themselves.
The problem is that Thunderbird's account wizard is based on an oversimplified model of the world. It might work for people who have a mailbox at one of the big email providers. But it fails miserably in environments where its basic assumptions are void (e.g. in corporate networks). It will bite you, regardless if you are an IT expert or not.

To get things done the trick is to somehow figure out how the wizard can be closed without destroying the newly created account. Once you have achieved this goal you can easily configure the account with the normal dialogs.

Unfortunately I cannot remember how I've managed it the last time I created a Thunderbird account. But let me say that for me it regularly takes less than ten minutes to defeat it.
As consuer21 said, Thunderbird's wizard is pretty much useless, as it has an oversimplified world view. Very well said.

Kurt came up with the same work around I've published for years, in similar bugs.

File - Offline - work offline
I propose to add a Manual Config button next to Continue, activate it the same way as for Continue, and skip all the auto stuff when clicked. Fields will be prefilled with user entered and default settings.  Magnus, will you r+ this?
Flags: needinfo?(mkmelin+mozilla)
I've suggested the old TBird 2.x approach which still works every time.

Basically what alta88 is suggesting. A straight up manual config.

Mail setups are just to complex for TBird or any product to guess about + get right.
(In reply to alta88 from comment #30)
> I propose to add a Manual Config button next to Continue, activate it the
> same way as for Continue, and skip all the auto stuff when clicked. Fields
> will be prefilled with user entered and default settings.  Magnus, will you
> r+ this?

We don't want it to be too easy to get into the manual config, since a lot of users won't know what to fill.
So I think adding a button next to the others may be a bit too much. But I'm open to some other way. Not sure exactly what would be best, but maybe something like a "Details..." link under the credentials fields, and following the link would go to the next page directly (same as skipping the autoconfig lookup). What do you think?
Flags: needinfo?(mkmelin+mozilla)
Unsure what "to easy" might mean.

Current wizard only works in a very limited number of cases, for example if you have a gmail account + fails 100% of time if not one of the few "known" mail systems, like gmail.

It's fine to have discovery.

The problem is when discovery fails + then Thunderbird config bricks (becomes unusable) with no way to proceed.

This is straight-up brain dead.

I still use Thunderbird-2.0.0.24 because I tend to setup many one-off email addresses to test client configs I host.

Trying to do this with any other version of TBird sucks to much time.
I don't think reducing a manual config option to obfuscation, effectively, is a good way to do it. It's still necessary to be able to read, so a button or something with Manual Config (label or tooltip 'You have the config info from your isp') is probably not going to be unclear to anyone. The corresponding Automatic Config (with some label) would make it even more clear.
I'm using thunderbird since MANY years with my own IMAP. In the first years it was possible to set all settings manually. Good old time ;-).

It would be VERY HELPFUL, if you implement this. Should not be a big deal.
Apple-Mail has a wizard, but if it fails, you can just press the "Next" and ignore the error message.

Possible workaround: Using a (working) different account or create a new one on a free mailer. After passing the wizard, the configuration is free :-). But I don't think this is the intention of not implementing this feature.   

P.S.: What's about "protection of data privacy". Why you send my data to the ISP Database, if I don't want it and it isn't needed?
Ah the good old days... when Thunderbird account setup was simple + took a few seconds.
What's it going to take to get anyone from the Thunderbird team to even acknowledge this bug? It's been open for TWELVE years now and still is not assigned to anyone!

Maybe we should start an email campaign to everyone on the Mozilla top executive.
This bug first occurred when Thunderbird 3x released, which is why I still use Thunderbird 2x.

Seems like the dev team has other priorities... other than fixing long standing bugs... er... feature problems...
What is the status of this bug? Is there a chance that tb developers fix it?
Just ran into it (again) when adding the account for my personal domain's mail server.
You need to log in before you can comment on or make changes to this bug.