Click Junk button while customizing toolbar marks mail as junk

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: brion, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: version 0.6+ (20040507)

When in 'Customize...' mode on the toolbar, it's expected that the toolbar
buttons are safe to click and drag around. However, the Junk button will
actually activate and mark mail as junk (or junk mail as not junk) if you click
it without dragging or drag it within the toolbar.

This also brings the main window to the foreground, obscuring the Customize
Toolbar dialog.

Reproducible: Always
Steps to Reproduce:
1. Select a message
2. Right-click toolbar, 'Customize...'
3. Click on "Junk"/"Not junk" button or drag it within the toolbar

Actual Results:  
Current message is marked as junk, or junk message is marked as not-junk.
Customize Toolbar dialog is hidden behind main window if single click instead of
drag.

Expected Results:  
Nothing should have happened on a single click. Dragging the button should not
activate junkness, just move the button.

Mac OS X 10.3.3, default Pinstripe theme.

Comment 1

15 years ago
can reproduce with Windows XP
OS: MacOS X → All

Comment 2

15 years ago
confirming as I've found no dupes.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: Macintosh → All

Comment 3

14 years ago
*** Bug 273481 has been marked as a duplicate of this bug. ***

Comment 4

13 years ago
This appears to have been fixed in the trunk; I can no longer reproduce with 
TB 1.0+0806, Win2K.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.