Closed Bug 244238 Opened 16 years ago Closed 15 years ago

Reflow should batch view updates

Categories

(Core :: Layout, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: bzbarsky, Unassigned)

References

Details

(Keywords: perf)

Basically, we should batch view updates around reflow command processing.  This
will have two primary benefits:

1)  Invalidates will get batched better by the viewmanager
2)  We won't have as much painting of absolute or fixed positioned elements
    during intermediate stages of reflow (the various bugs where things flicker
    briefly in some random corner, etc).

To do this right we have to fix viewmanager to propagate update batches to the
root viewmanager.  Roc, should that all just happen in one patch (since the
presshell part is all of two lines long), or should the viewmanager changes get
a separate bug?
Should probably fix it in two stages (view manager first, of course) to make it
easier to catch regressions.
Depends on: 244290
Makes sense.  Bug 244290 filed for the viewmanager part.
Fixed by patch in bug 262760.  Not sure why we thought this depended on bug 244290..
Blocks: 203448
OS: Linux → All
Hardware: PC → All
Re comment #3. Does that mean this bug is fixed?
Yes, this is fixed.  I tried to mark it so in comment 3.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
Component: Layout: Misc Code → Layout
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.