If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

non-xft builds crash X server when viewing pages with unrecognized unicode characters

RESOLVED INVALID

Status

()

Core
Layout: Text
--
critical
RESOLVED INVALID
14 years ago
12 years ago

People

(Reporter: Hannes Mayer, Unassigned)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510
Build Identifier: http://ftp.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla1.7rc2/

Non-XFT enabled builds (-> official mozilla.org builds; tested 1.7RC1, 1.7RC2,
1.8alpha) crash the X server on Fedora 2 when viewing pages with unrecognized
unicode characters. See the links for examples:

A png of the characters causing the X crash:
http://www.captn.net/character.png

This page with just 2 characters crashes X on Fedora 2 with 1.7RC1, 1.7RC2 and
1.8alpha (non-xft):
http://www.captn.net/mozilla-crash.html

This is especially annoying when such characters appear in google SERP's!

Can't come up with any useful error-messages yet. Reasons:

* X crashes only with:
Fatal server error:
Caught signal 11.  Server aborting

* mozilla -g | tee mozdbg.txt
stops writing to the file as soon as X crashes

If you have any other ideas on getting error messages, I'd be more than happy to
post them.

Thanks a lot!


Reproducible: Always
Steps to Reproduce:
1. Install any recent non-xft mozilla-build on Fedora 2
2. View the page mentioned above
3. X server crashes

Actual Results:  
X server crashed. Sometimes hard hang of the system

Expected Results:  
If certain unicode characters can't be displayed in non-xft builds, just display
a "?" or a small square as seen in the windows-build

Talkback doesn't come up since X crashes
What X server version is this?  I don't get a crash with a current Linux build
on RH8 (XFree86 4.2.0)

Comment 2

14 years ago
wfm Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a) Gecko/20040519
SuSE 9.1, XFree86-4.3.99.902-40
Keywords: crash
(Reporter)

Comment 3

14 years ago
Fedora 2 now uses Xorg:
# X -version
 
Release Date: 18 December 2003
X Protocol Version 11, Revision 0, Release 6.7

Thanks!
Have you filed a bug on the Xorg folks, given that their server is crashing?
(Reporter)

Comment 5

14 years ago
I just filed it:
http://freedesktop.org/cgi-bin/bugzilla/show_bug.cgi?id=659

I will cross-update both bugzilla entries.

Comment 6

14 years ago
I filed this with Red Hat a while back:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=121403
(Reporter)

Comment 7

14 years ago
Created attachment 150126 [details]
strace startx 2> stracestartx.txt

I figured out how to use strace for this bug.
On my Fedora-box:
failsave-terminal
# telinit 3
# strace startx 2> stracestartx.txt
Opened mozilla, loaded the crashing-page, X crashed...
(Reporter)

Comment 8

14 years ago
Created attachment 150127 [details]
strace mozilla 2> stracemozilla.txt

This is the strace when logged in in GNOME and calling mozilla from the
terminal.
strace mozilla 2> stracemozilla.txt

Comment 9

13 years ago
*** Bug 252987 has been marked as a duplicate of this bug. ***

Comment 10

13 years ago
*** Bug 266526 has been marked as a duplicate of this bug. ***

Comment 11

13 years ago
resolving as IVNALID

this is an xorg bug.  you can work around it by disabling xfs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Comment 12

13 years ago
*** Bug 275449 has been marked as a duplicate of this bug. ***

Comment 13

13 years ago
WFM

Comment 14

13 years ago
*** Bug 283112 has been marked as a duplicate of this bug. ***

Comment 15

13 years ago
Shouldn't this bug be reassigned ? 
See  Jungshik's comment https://bugzilla.mozilla.org/show_bug.cgi?id=283112#c11 
“mozilla.org default build will be switched to gtk2 + xft very soon.”

There is a slight confusion : This is *not* a X server crash but a clean
emergency exit. In case of a crash, (try "killall" "X in a root console and then
ps -Al|grep yourid. : there might be many zombies) Even Mozilla which send the
termination control to X probably doesn't crash at all but is killed by X which
terminate session
So, i don't mind if it is pathological or not that X accepts control sequence
from an application but this is unfair that mozilla send it...

Comment 16

12 years ago
*** Bug 307398 has been marked as a duplicate of this bug. ***

Comment 17

12 years ago
*** Bug 316739 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.