Closed Bug 244510 Opened 19 years ago Closed 4 years ago

reports/log files generated with Veritas/Symantec BackupExec use window.event (can't expand subsections)

Categories

(Web Compatibility :: Desktop, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: cmflatscher, Unassigned)

References

()

Details

(Whiteboard: [country-all] [contactready] [app])

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113

Hi,

I have created with Veritas BackupExec v9.0 and v9.1 backups and then generated
log files in HTML format. I then tried to review them with Mozilla v1.4.2,
v1.7RC2, v1.8a1, and FireFox v0.8 under Windows NT 4.0 SP6a and Windows 2000. I
have also installed Sun's Java RTM J2RE v1.4.2.03.

I can open up the file but I am not able to expand or collapse any sections.
However I can happily do this with Mircosofts Internet Exploder v6.0 + SP1. I
have the assumption that Veritas has designed the documents to only open
properly with IE.

I can provide you with some sample log files.

Is there any chance to review and maybe solve this matter?

Thanks!

--Christian

Reproducible: Always
Steps to Reproduce:
1. Launch Mozilla / FireFox
2. Open Vertias BackupExec v9.x log file


Actual Results:  
Can't expand / collapse sections of the doucments

Expected Results:  
Hopefully update Mozilla code to properly display Veritas Log files
can you attach one of these files via "create a new attachment" ?
Hi,

I have uploaded a ZIP file that contains 6 sample log files for review. I hope
they help you in finding a solution to the raised problem. Thanks.

--Christian
Attachment #149254 - Attachment is obsolete: true
when clicking on the '-' sign, JS console shows:

Error: event is not defined

source shows:
[...]
  function outliner()
  {
    var srcElement = event.srcElement;
[...]
which will only work on IE.

This URL shows the IE/Moz differences http://www.quirksmode.org/dom/w3c_events.html
Assignee: parser → english-us
Status: UNCONFIRMED → NEW
Component: HTML: Parser → English US
Ever confirmed: true
OS: Windows 2000 → All
Product: Browser → Tech Evangelism
QA Contact: english-us
Hardware: PC → All
Version: Trunk → unspecified
Veritas needs to be contacted, if you're a customer, best way is to open a
ticket/case/service request:
http://seer.support.veritas.com/email_forms/

Their release notes 9.1/9.0 don't mention anything about fixing NS7/Mozilla
compatibility:
http://seer.support.veritas.com/docs/267182.htm
Hi Olivier,

many thanks for all your efforts. I understand that the Mozilla folks will not
sort out a deliberate standards violation from MS.

I have reaised the matter with Veritas. I hope that they will fix this matter as
I find it personally very dissatisfying if you must use Windows and IE to review
logs.

Thanks again.

--Christian
Hi,

I have been in discussion with Veritas and they only support the use of IE5.x
when reviewing their log files.

Is there anything else you can help me with?

Many thanks.

--Christian
*** Bug 318291 has been marked as a duplicate of this bug. ***
*** Bug 235296 has been marked as a duplicate of this bug. ***
*** Bug 320790 has been marked as a duplicate of this bug. ***
Summary: Mozilla not able to display Veritas BackupExec v9.x log files → reports/log files generated with Veritas/Symantec BackupExec use window.event (can't expand subsections)
Duplicate of this bug: 502013
In 2011, it was still a thing 
http://www.symantec.com/connect/pt-br/forums/backup-reports-not-compatible-firefox-chrome
Assignee: english-us → nobody
Component: English US → Desktop
Whiteboard: [country-all] [contactready] [app]
Depends on: 218415
Priority: -- → P3
So, window.event exists not, but this still doesn't work:

> TypeError: srcElement.parentElement.parentElement.all

But it also doesn't work in Chrome. I suggest we WONTFIX. If someone disagrees, please re-open and probably the best course of action is to get in touch with the site.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.