Closed Bug 244871 Opened 16 years ago Closed 15 years ago

Open in Tabs re-uses existing tabs

Categories

(Firefox :: Tabbed Browser, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 216346

People

(Reporter: kevinar18, Assigned: bugs)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040527 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040527 Firefox/0.8.0+

Should "Open in Tab" reuse current windows?  I actually do not know if it should
or not.  I merely wanted to bring this up in case it happens to be a bug.

Reproducible: Always
Steps to Reproduce:

1. Open two tabs.
2. Find a boomark folder with two URLs. Click "Open in New Tabs"
Actual Results:  
The two tabs you have opened are replaced with the links.


I'm not sure if it is appropriate to reuse the tabs or not.  This could be a
potential dataloss issue, however this may also be considered a feature.  I only
wish to bring up the issue.  If it is a bug, then it is a datloss issue.  If it
is a feature, then leave it as is.

On a personal note, normal bookmarks re-use the active window or tab that you
are using, thus it seems logical from a theoretical standpoint that "Open in
Tabs" should re-use the tabs you have open.  Thus, for the sake of consistency,
leaving the feature as is, would be preferred.  On the other hand, it is also
natural (when first encountering the feature) to expect the tabs to be new tabs.
It's supposed to do that by default.

To stop it from doing that, go to about:config and change the value of
browser.tabs.loadFolderAndReplace to false.
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → WORKSFORME
*** Bug 244875 has been marked as a duplicate of this bug. ***
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago16 years ago
Resolution: --- → INVALID
*** Bug 278468 has been marked as a duplicate of this bug. ***
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

*** This bug has been marked as a duplicate of 216346 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago15 years ago
Resolution: --- → DUPLICATE
This bug is CRITICAL! - users loose their data.
Bug exists very long time (from v0.9 as I remember), but nobody bothers about
that :(
QA Contact: tabbed.browser
You need to log in before you can comment on or make changes to this bug.