horizontal line (hr) overlap (moz-float-edge) right float

VERIFIED FIXED

Status

()

Core
Layout
--
major
VERIFIED FIXED
13 years ago
10 years ago

People

(Reporter: octavian costache, Unassigned)

Tracking

(Depends on: 1 bug, {testcase})

Trunk
x86
All
testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments, 2 obsolete attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040514
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040514

In the page http://olimpiada.info/bynet/index.php the horizontal line ovelapes a
table that is aligned to the right.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
This needs a minimal testcase.
Keywords: qawanted
Created attachment 149487 [details]
Simple testcase

It only happens with <hr size="1">
According to:
http://www.w3.org/TR/REC-html40/present/graphics.html#h-15.3
it sets the height of the rule, but in Mozilla it seems to set the
border-widths of the rule, the height of the rule stays 0px.
Interesting.  Looks like having only a top border and no side borders confuses
moz-float-edge.... (setting side borders on those overlapping hrs makes them
stop overlapping).

I swear I've seen a bug on that before, but I can't find it... :(
Keywords: qawanted
Summary: horizontal line (hr) not displayed properly → horizontal line (hr) not displayed properly (moz-float-edge)
Whiteboard: DUPEME

Comment 4

13 years ago
Bug 246179 is similar to this one:
http://bugzilla.mozilla.org/show_bug.cgi?id=246179

I think Mozilla added extra left margin to the horizontal rules... See how the
page is forced to scroll horizontally.
Blocks: 246179
This seems to have regressed.
The simple testcase works in: 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/2004-01-15
Firebird/0.8.0+
But it doesn't work in:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/2004-01-20
Firebird/0.8.0+

Backing out the patch for bug 52916 fixes the testcase for this bug.
Created attachment 150704 [details] [diff] [review]
I meant backint out this line of text

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Created attachment 151614 [details] [diff] [review]
workaround patch for html.css

Or html.css could be changed, so the bug would become less visible.
*** Bug 265463 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Depends on: 69490

Updated

13 years ago
Keywords: testcase

Updated

13 years ago
OS: Windows XP → All
Summary: horizontal line (hr) not displayed properly (moz-float-edge) → horizontal line (hr) overlap (moz-float-edge) right float
Whiteboard: DUPEME

Comment 9

13 years ago
*** Bug 273145 has been marked as a duplicate of this bug. ***
*** Bug 281693 has been marked as a duplicate of this bug. ***
(In reply to comment #7)
> Created an attachment (id=151614) [edit]
> workaround patch for html.css

Good idea, the problem with this patch is that it increases the box height
from 1px to 2px and that it changes the border-bottom-color to transparent
which makes the following bottom border invisible:
<hr size="1" style="border-bottom-width: 5px; border-bottom-style:solid">
Created attachment 173924 [details] [diff] [review]
html.css patch, rev. 2

Something like this perhaps
I think it could be worth taking this as a wallpaper until moz-float-edge
sucks less.
So why not set only what we want to set?  That is:

border-top-style: -moz-bg-solid
border-right: 1px solid transparent;
border-left: 1px solid transparent;

(if the border-left is needed) and not mess with border-bottom at all?
Created attachment 174333 [details] [diff] [review]
Like this?

Like this?
Indeed, border-left is not needed to fix the testcase. I haven't really tried
this on other testcases or url's.
Attachment #150704 - Attachment is obsolete: true
Attachment #151614 - Attachment is obsolete: true

Updated

13 years ago
Attachment #174333 - Attachment is patch: true
Attachment #174333 - Attachment mime type: application/octet-stream → text/plain
Hmm... Except we do want to turn off the bottom border from the "hr" rule...
Maybe the right thing is:

border-top-style: -moz-bg-solid;
border-bottom-style: none;
border-right: 1px solid transparent;
border-left: 1px solid transparent;

(and I'd like to leave left and right symmetric, yes).

Note that that (as all proposed solutions to this bug) introduces an issue with
<hr width="100%">, though...

Comment 17

12 years ago
is bug#267353 same as this?
No.
Blocks: 267353

Comment 19

11 years ago
Testcase wfm.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061214 Minefield/3.0a1
Works in 2006-12-08-01 but not in 2006-12-07-01.  Fixed by reflow branch landing.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Depends on: 300030
Resolution: --- → FIXED

Updated

11 years ago
Duplicate of this bug: 366039
Created attachment 257614 [details] [diff] [review]
Reftests
Attachment #257614 - Flags: review?(dbaron)
No longer blocks: 246179
Duplicate of this bug: 246179
Comment on attachment 257614 [details] [diff] [review]
Reftests

Checked in after testing in pre- and post-reflow-branch builds.
Attachment #257614 - Flags: review?(dbaron) → review+
Status: RESOLVED → VERIFIED
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.