table resized with div float (-moz-float-edge issue)

VERIFIED FIXED

Status

()

Core
Layout
VERIFIED FIXED
14 years ago
12 years ago

People

(Reporter: LittLe3Lue, Unassigned)

Tracking

(Depends on: 1 bug, {testcase})

1.7 Branch
x86
Windows XP
testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

When creating a floating div in a table, it appears to resize the table for
other blovk level components.

I did not test for all, but <HR /> will stretch out past the div's width.

Web developer tools still outline the table as beings its normal width.

Reproducible: Always
Steps to Reproduce:
1.Make a <table> with a set width, smaller than page width.
2.Add a div with (for example) style="float:left; width:100px;" inside a <td>
3.Add a <hr>

Actual Results:  
the HR will stretch out of the table size.

Expected Results:  
the hr should stay within the table dimensions.  Just like text does.

FireFox 1.0 Preview Release
Base Theme
Not many extensions, all of which are popular.

Comment 1

14 years ago
CAn you please attach a testcase showing the problem?
https://bugzilla.mozilla.org/attachment.cgi?bugid=267353&action=enter
Assignee: firefox → nobody
Component: General → Layout
Product: Firefox → Browser
QA Contact: firefox.general → core.layout
Version: unspecified → 1.7 Branch
(Reporter)

Comment 2

14 years ago
Created attachment 164609 [details]
this is an example of how an HR can stretch outside of a table it is in

I am running Firefox 0.10 RC2 which i downloaded today.. and this is still a
bug.
This is an issue with -moz-float-edge, and almost certainly a duplicate.
Summary: table resized with div float → table resized with div float (-moz-float-edge issue)
Whiteboard: DUPEME

Updated

14 years ago
Keywords: testcase

Comment 4

13 years ago
Created attachment 205583 [details]
<hr style="height:1px;">

almost same as 244932 I use <hr style="height:1px;"> in my attachemt

Comment 5

13 years ago
oops...
> almost same as bug# 244932 


Works in 2006-12-08-01 but not in 2006-12-07-01.  Fixed by reflow branch landing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Depends on: 300030
Resolution: --- → FIXED
This is really similar to bug 244932, but I'm going to make a reftest for it anyway since the testcase does have a different usage scenario.
Whiteboard: DUPEME
Created attachment 257628 [details] [diff] [review]
Reftests
Attachment #257628 - Flags: review?(dbaron)
Comment on attachment 257628 [details] [diff] [review]
Reftests

Checked in after testing in pre- and post-reflow-branch builds.
Attachment #257628 - Flags: review?(dbaron) → review+
Status: RESOLVED → VERIFIED
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.