Changes to attached file lost when Thunderbird is closed

RESOLVED DUPLICATE of bug 220808

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 220808
14 years ago
14 years ago

People

(Reporter: Frode Moretro, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

If you receive an e-mail with an attached file, and you open this attached file
directly from Thunderbird, you will loose any changes you make to this file when
Thunderbird is closed.

Reproducible: Always
Steps to Reproduce:
1. Receive a mail with an attached Word document.
2. Double-click the attached file and see it open in Word.
3. Edit the document in Word for 8 hours.
4. Save your changes.
5. Exit Word.
6. Exit Thunderbird.
7. Re-open Word and look for your file.


Actual Results:  
The changed file is lost.

Expected Results:  
Keep the changes.

Attached files are saved by default in a Temp folder under the current User
(when you open attachments directly from the Thunderbird mail window).  This
Temp folder is being cleaned up by Thunderbird when you exit.

There is an easy workaround:  Save the attachment to disk before opening.
There is a problem with this workaround:  None of the users that I have coerced
into using Thunderbird "to save you from losing data to virii etc." would have
thought of that.

Comment 1

14 years ago
I would say this is a dupe of Bug 220808.

Comment 2

14 years ago
Agreed on dupe.

*** This bug has been marked as a duplicate of 220808 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.