All users were logged out of Bugzilla on October 13th, 2018

[OSX, AVIARY_BRANCH] build error(link error on thunderbird-bin)

RESOLVED FIXED in Thunderbird0.7

Status

--
blocker
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: sugar.waffle, Assigned: mscott)

Tracking

unspecified
Thunderbird0.7
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
build was tried by AVIARY_1_0_20040515_BRANCH.
But an error generates the last thunderbird-bin in creation.
build was made of 1.7BRANCH satisfactory using the same .mozconfig.

Mac OS X 10.3.4

.mozconfig

. $topsrcdir/mail/config/mozconfig

ac_add_options --enable-strip
ac_add_options --enable-optimize="-O2"
ac_add_options --enable-prebinding
ac_add_options --disable-tests
ac_add_options --disable-debug
ac_add_options --disable-dtd-debug
ac_add_options --disable-jsd
ac_add_options --disable-logging
ac_add_options --disable-logrefcnt
ac_add_options --disable-profilesharing

-------
termnal log:
c++ -o thunderbird-bin  -fno-rtti -fno-exceptions -Wall -Wconversion
-Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy
-Wno-non-virtual-dtor -Wno-long-long -O2 -fpascal-strings -no-cpp-precomp
-fno-common -fshort-wchar -I/Developer/Headers/FlatCarbon -pipe  -DNDEBUG
-DTRIMMED -O2  nsMailApp.o     -L../../dist/bin -L../../dist/lib
../../dist/lib/libxulapp_s.a -L../../dist/bin -lmozjs -L../../dist/bin -lxpcom
-L../../dist/bin
-L/Users/sek/Documents/mozilla-current/thunderbird/mozilla/dist/lib -lplds4
-lplc4 -lnspr4 -lpthread  -framework Carbon   -lm      
ld: warning multiple definitions of symbol _PL_ArenaAllocate
../../dist/bin/libplds4.dylib(plarena.o) definition of _PL_ArenaAllocate
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork(plarena.o)
definition of _PL_ArenaAllocate
ld: warning multiple definitions of symbol _PL_InitArenaPool
../../dist/bin/libplds4.dylib(plarena.o) definition of _PL_InitArenaPool
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork(plarena.o)
definition of _PL_InitArenaPool
ld: warning multiple definitions of symbol _PL_FreeArenaPool
../../dist/bin/libplds4.dylib(plarena.o) definition of _PL_FreeArenaPool
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork(plarena.o)
definition of _PL_FreeArenaPool
ld: warning multiple definitions of symbol _PL_FinishArenaPool
../../dist/bin/libplds4.dylib(plarena.o) definition of _PL_FinishArenaPool
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork(plarena.o)
definition of _PL_FinishArenaPool
ld: warning multiple definitions of symbol _PL_ArenaRelease
../../dist/bin/libplds4.dylib(plarena.o) definition of _PL_ArenaRelease
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork(plarena.o)
definition of _PL_ArenaRelease
ld: warning multiple definitions of symbol _PL_ArenaGrow
../../dist/bin/libplds4.dylib(plarena.o) definition of _PL_ArenaGrow
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork(plarena.o)
definition of _PL_ArenaGrow
ld: warning multiple definitions of symbol _PL_ArenaFinish
../../dist/bin/libplds4.dylib(plarena.o) definition of _PL_ArenaFinish
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork(plarena.o)
definition of _PL_ArenaFinish
ld: warning multiple definitions of symbol _PL_CompactArenaPool
../../dist/bin/libplds4.dylib(plarena.o) definition of _PL_CompactArenaPool
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork(plarena.o)
definition of _PL_CompactArenaPool
ld: warning multiple definitions of symbol _PR_GetError
../../dist/bin/libnspr4.dylib(prerror.o) definition of _PR_GetError
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork(nsprPortX.o)
definition of _PR_GetError
ld: warning multiple definitions of symbol _PR_Free
../../dist/bin/libnspr4.dylib(prmem.o) definition of _PR_Free
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork(nsprPortX.o)
definition of _PR_Free
ld: warning multiple definitions of symbol _PR_DestroyLock
../../dist/bin/libnspr4.dylib(ptsynch.o) definition of _PR_DestroyLock
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork(nsprPortX.o)
definition of _PR_DestroyLock
ld: warning multiple definitions of symbol _PR_Calloc
../../dist/bin/libnspr4.dylib(prmem.o) definition of _PR_Calloc
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork(nsprPortX.o)
definition of _PR_Calloc
ld: warning multiple definitions of symbol _PR_Realloc
../../dist/bin/libnspr4.dylib(prmem.o) definition of _PR_Realloc
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork(nsprPortX.o)
definition of _PR_Realloc
ld: warning multiple definitions of symbol _PR_NewLock
../../dist/bin/libnspr4.dylib(ptsynch.o) definition of _PR_NewLock
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork(nsprPortX.o)
definition of _PR_NewLock
ld: warning multiple definitions of symbol _PR_Malloc
../../dist/bin/libnspr4.dylib(prmem.o) definition of _PR_Malloc
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork(nsprPortX.o)
definition of _PR_Malloc
ld: warning multiple definitions of symbol _PR_Lock
../../dist/bin/libnspr4.dylib(ptsynch.o) definition of _PR_Lock
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork(nsprPortX.o)
definition of _PR_Lock
ld: warning multiple definitions of symbol _PR_CeilingLog2
../../dist/bin/libnspr4.dylib(prlog2.o) definition of _PR_CeilingLog2
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork(nsprPortX.o)
definition of _PR_CeilingLog2
ld: warning multiple definitions of symbol _PR_GetOSError
../../dist/bin/libnspr4.dylib(prerror.o) definition of _PR_GetOSError
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork(nsprPortX.o)
definition of _PR_GetOSError
ld: warning multiple definitions of symbol _PR_Unlock
../../dist/bin/libnspr4.dylib(ptsynch.o) definition of _PR_Unlock
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork(nsprPortX.o)
definition of _PR_Unlock
ld: warning multiple definitions of symbol _PR_SetError
../../dist/bin/libnspr4.dylib(prerror.o) definition of _PR_SetError
/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork(nsprPortX.o)
definition of _PR_SetError
ld: warning prebinding disabled because of undefined symbols
ld: Undefined symbols:
.objc_class_name_NSBundle
.objc_class_name_NSMutableArray
.objc_class_name_NSString
.objc_class_name_NSTask
_objc_msgSend
make[4]: *** [thunderbird-bin] Error 1
make[4]: Leaving directory
`/Users/sek/Documents/mozilla-current/thunderbird/mozilla/mail/app'
(Reporter)

Comment 1

15 years ago
The problem similar to this was contributed to the Firefox build forum of
MozillaZine.
 See : http://forums.mozillazine.org/viewtopic.php?t=81272
Although I performed static link build similarly, a problem is not in this.

Possibly, in AVIARY_BRANCH, if build is performed by the dynamic link, it may be
that there is a problem.

This problem is not seen by trunk and 1.7branch.
(Reporter)

Updated

15 years ago
Summary: [OSX, AVIARY_BRANCH] build error → [OSX, AVIARY_BRANCH] build error(link error on thunderbird-bin)

Comment 2

15 years ago
That post at MozillaZine was me. My .mozconfig is slightly more barebones than
croto's:

. $topsrcdir/mail/config/mozconfig

ac_add_options --disable-debug
ac_add_options --enable-optimize=-O2
ac_add_options --enable-official-branding 
(Assignee)

Comment 3

15 years ago
Jon, I just checked in the fix for this. You should be good to go now. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird0.7
You need to log in before you can comment on or make changes to this bug.