Closed Bug 245264 Opened 17 years ago Closed 8 years ago

Tooltip for disabled toolbar item should explain why it's disabled

Categories

(Firefox :: Toolbars and Customization, defect)

x86
Windows XP
defect
Not set
trivial

Tracking

()

RESOLVED WONTFIX

People

(Reporter: richard.corbin, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040601 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040601 Firefox/0.8.0+

When hovering over a disabled toolbar button (e.g. the Stop button once a page
has finished loading), the tooltip (Stop Loading this Page) still appears. This
is true for all other buttons on this toolbar.

I think that disabled buttons should display one of the following:
 1. "Button Disabled"
 2. "<Standard Tooltip> (Disabled)" (e.g. "Stop Loading this page (disabled)")
 3. "<Explanation into why button disabled>" (e.g. "The Stop button is disabled
as the page is fully loaded")

Reproducible: Always
Steps to Reproduce:
1. Ensure a toolbar button is disabled (e.g. Stop button once a page has
finished loading)
2. Hover over the stop button
3. View tooltip

Actual Results:  
Stop button shows the standard tooltip ... 'stop loading this page'

Expected Results:  
Stop button should show something else (outlined above).

As already mentioned, this is true for all toolbar buttons. I have only used the
stop button as an example.
Forgot this.

Alternative is that no tooltip is shown (though I think that one of the 3
suggestions I made in the description is the user friendly option)
The 3 Windows programs I tested all do the same thing Firefox does: they display
the same tooltip regardless of whether the button is enabled.

> 1. "Button Disabled"

Tooltips are shown for disabled toolbar buttons because users need to be able to
find out what disabled buttons are for (see bug 39358).  Changing the tooltip to
"Button disabled" would defeat the purpose of the tooltip.

> 2. "<Standard Tooltip> (Disabled)" (e.g. "Stop Loading this page (disabled)")

"(disabled)" is redundant.  The user can see that the button is disabled.

> 3. "<Explanation into why button disabled>" (e.g. "The Stop button is disabled
as the page is fully loaded")

How about combining the normal tooltip with an explanation of why it's disabled?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Jesse (comment #2):

"combining the normal tooltip with an explanation of why it's disabled"

That sounds like a very good idea, and I'd like to see it implemented.

Possibly the severity should be changed to enhancement if so?
I like the idea of combining with explination. Might be more "new-user" friendly.
Summary: Disabled toolbar items should not display tooltip (or if they do it should be clear that button is currently disabled) → Tooltip for disabled toolbar item should explain why it's disabled
Assignee: bugs → nobody
QA Contact: bugzilla → toolbars
As comment #2 mentions, this would be different than what is expected platform behavior. Many of our buttons, when disabled, have an obvious reason behind why they are disabled. For example, if the Back button is disabled the tooltip would read:
"Go back one page
Right-click or pull down to show history
(Disabled because you cannot go back)"

This doesn't seem to help users and isn't worth us implementing the feature. We would be better off finding ways to remove buttons that are disabled often and making our button definitions clearer so users don't need to rely on tooltips.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.