Closed Bug 245432 Opened 17 years ago Closed 17 years ago

Initial homepage with fresh install (installer build, new profile) is empty, not blank, empty

Categories

(Firefox :: Installer, defect)

x86
Windows XP
defect
Not set
minor

Tracking

()

VERIFIED DUPLICATE of bug 245433

People

(Reporter: tmeader, Assigned: bugs)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040602 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040602 Firefox/0.8.0+

When installing Firefox with an installer build, after it loads for the first
time (with a new profile), the homepage it defaults to is empty. I don't mean
it's "blank" as in "about:blank"... the fields is completely empty.

Reproducible: Always
Steps to Reproduce:
1.Install Firefox from an installer build with a new profile
2.Launch Firefox
3.

Actual Results:  
The default homepage is completely empty.

Expected Results:  
It should default to the Firefox page on Mozilla.org, or at the very least
"about:blank"
Confirm problem ....

The installer build has

browser.startup.homepage = chrome://browser-region/locale/region.properties
browser.startup.page = 1

The zip build has the homepage set to the products page URL.

The installer build is presently causing the sessionsaver extension to create 
an exception because of the homepage address on first load.
Possibly related: bug 245271, where browser.throbber.url is being found pointing
to the same chrome: URL in installer builds.
confirming this behaviour on...
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040601
Firefox/0.8.0+ (installer)

... with a clean install of course
confirming this behaviour on another installer build:

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040602
Firefox/0.8.0+
I also see this using a build from June 2, 2004.
Blocking 0.9?
Flags: blocking0.9?
This was caused by the patch in bug 245433, which was partly backed out.

*** This bug has been marked as a duplicate of 245433 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Flags: blocking0.9?
Resolution: --- → DUPLICATE
Sorry that was incorrect. Bug 245433 indeed fixed this problem. The bustage that
bug caused was backed out, but the fix remains.
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.