Status bar indicator for download-manager

VERIFIED DUPLICATE of bug 402278

Status

()

--
enhancement
VERIFIED DUPLICATE of bug 402278
15 years ago
11 years ago

People

(Reporter: rosenauer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
It would be handy if there was an indicator for the download-manager in the
statusbar.

Generally, I prefer the download-manager to work silently in the background, but
at the same time I'd like to see if a download I initiated has already started
(there's only a popup when all downloads have finished).
So I'd have an eye on my downloads without having to invoke the otherwise superb
(thanks!) downloadmanager just to get an idea of the progress.

In addition, this indicator could have a (toggable?) time/percentage attached to
it or popping up when "moused over", and change when one or more downloads have
failed or finished.
I think this is more towards extension fodder.  Cluttering up the status bar
just makes it less likely that critical notifications (i.e. secure connections
and blocked popups) won't be seen.  It also means a bunch of notifications and
listeners to keep it in sync with all open windows, which gets messy and bloaty.

Updated

15 years ago
Severity: normal → enhancement
OS: Windows XP → All
Hardware: PC → All

Comment 2

14 years ago
*** Bug 263720 has been marked as a duplicate of this bug. ***

Comment 3

14 years ago
Created attachment 167385 [details]
Word Document shows screen capture of error for Download Manager

Documents that shows screen capture of error on the Title Bar of download
manager.

Comment 4

14 years ago
Comment #3 would be more relevant for bug# 282310

Updated

12 years ago
QA Contact: ali → download.manager
Assignee: bugs → nobody

Comment 5

11 years ago
Fixed by bug 402278 ! :)
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 402278
Nice; verified dup.  I'm actually liking this a lot.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

11 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.