"Add to Address Book ..." pane isn't filling in

RESOLVED DUPLICATE of bug 245325

Status

SeaMonkey
MailNews: Address Book & Contacts
RESOLVED DUPLICATE of bug 245325
14 years ago
13 years ago

People

(Reporter: Scott Kraft, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040604
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2) Gecko/20040604

When in mail/news and right clicking on From address, select "Add to Address
Book." The pane comes up for a new contact, but the email address isn't
automatically filled in - as it was in previous builds.

Reproducible: Always
Steps to Reproduce:
1. Open mail message.
2. Right click on "From" email address.
3. Select "Add to Address Book". A new contact window appears, but it isn't
populated with the selected email address.

Actual Results:  
A new contact window appears, but it isn't populated with the selected email
address.

Expected Results:  
The window should appear with the email address field populated with the
selected address.
I think mscott has a tbird bug about this.

skraft:  is it with all messages, or specific emails?
Status: UNCONFIRMED → NEW
Ever confirmed: true
never mind, I can easily reproduce this!
here's the js error on my console.

JavaScript error: chrome://messenger/content/addressbook/abCardOverlay.js, line
136: setting a property that has only a getter

let's hope 1.7 branch doesn't have this.

accepting
Status: NEW → ASSIGNED
> let's hope 1.7 branch doesn't have this.

luckily, it doesn't appear to have this regression.
this scenario, where no ab is selected, shouldn't be in this code.

see
http://lxr.mozilla.org/mozilla/source/mailnews/addrbook/resources/content/abCardOverlay.js#130

130     if ( editCard.selectedAB && menupopup && menupopup.childNodes )
131     {
132       for ( var index = menupopup.childNodes.length - 1; index >= 0; index-- )
133       {
134         if ( menupopup.childNodes[index].getAttribute('value') ==
editCard.selectedAB )
135         {
136           abPopup.label = menupopup.childNodes[index].getAttribute('label');
137           abPopup.value = menupopup.childNodes[index].getAttribute('value');
138           break;
139         }
140       }
141     }
142     else {
143       // Default to the first valid addressbook when none is
144       // selected. (the 0th is an empty/invalid entry)
145       abPopup.label = menupopup.childNodes[1].getAttribute('label');
146       abPopup.value = menupopup.childNodes[1].getAttribute('value');
147     }
ignore that last comment.

something might have changed with menulists and how we are abusing them /
misusing them.

see bug #245325

*** This bug has been marked as a duplicate of 245325 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.